incubator-clerezza-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hasan <ha...@apache.org>
Subject Re: Try to use felix 2.1.0-SNAPSHOT
Date Fri, 22 Jan 2010 15:42:52 GMT
Tsuyoshi Ito wrote:
> Hi there
>
> Try to update clerezza.platform.launcher.storageless to use felix 2.1.0-SNAPSHOT instead
of 1.4.1 because of felix framework.security (see FELIX-1101: https://issues.apache.org/jira/browse/FELIX-1101).

>
> When starting launcher.sesame on 
>
> FreeBSD 7.0-RELEASE-p3
>
> java version "1.6.0_07"
> Diablo Java(TM) SE Runtime Environment (build 1.6.0_07-b02)
> Diablo Java HotSpot(TM) Server VM (build 10.0-b23, mixed mode)
>
> the following error occured:
>
> The activate method has thrown an exception
> java.lang.AbstractMethodError: org.apache.felix.framework.SecurityProviderImpl.getSignerMatcher(Lorg/osgi/framework/Bundle;I)Ljava/lang/Object;
> ...
> [SCR Component Actor] ERROR org.apache.clerezza.platform.security - [org.apache.clerezza.platform.security.PermissionManager]
Component instance could not be created, activation failed
>
> I am not sure if I did something wrong because
>
> hasan tested it successfully on his linux machine (unbuntu, don't know which version
of the VM)
I have the same version
$ java -version
java version "1.6.0_07"
Java(TM) SE Runtime Environment (build 1.6.0_07-b06)
Java HotSpot(TM) Server VM (build 10.0-b23, mixed mode)

Cheers
hasan

> Cheers
> TSuy
>
>   

Mime
View raw message