incubator-chukwa-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mohammad Tariq <donta...@gmail.com>
Subject Re: No Collector.pid file
Date Thu, 17 Nov 2011 07:15:35 GMT
Hi Eric,
  Thanks a lot for the info.

Regards,
    Mohammad Tariq



On Thu, Nov 17, 2011 at 12:44 PM, Eric Yang <eric818@gmail.com> wrote:
> Hi Tariq,
>
> Chukwa hicc and collector are designed to run on different servers.
> Hence, it is probably best to use alternative port for Chukwa
> collector.  The port number for Chukwa collector can be adjusted in
> chukwa-collector-conf.xml with chukwaCollector.http.port setting.
> "collectors" file should contain http://localhost:8090/ for agent to
> push events to collector.
>
> regards,
> Eric
>
> On Wed, Nov 16, 2011 at 11:04 PM, Mohammad Tariq <dontariq@gmail.com> wrote:
>> Hi Ahmed,
>>
>>   When I am pointing my web browser to " http://localhost:8080/hicc "
>> the only thing which I can see on the browser is " Chukwa servlet
>> running "..and in the logs it is showing that address 8080 is already
>> in use, although I have changed the tomcat port to 8090.I am using
>> 0.4.0..What might be the cause???
>>
>> Regards,
>>     Mohammad Tariq
>>
>>
>>
>> On Thu, Nov 17, 2011 at 11:54 AM, Mohammad Tariq <dontariq@gmail.com> wrote:
>>> Hello Ahmed,
>>>
>>>   Sure, i'll try and contact you on the list if I face any
>>> problem..Who else do I have when it comes to Chukwa...;)
>>>
>>> Regards,
>>>     Mohammad Tariq
>>>
>>>
>>>
>>> On Thu, Nov 17, 2011 at 11:50 AM, Ahmed Fathalla <afathalla@gmail.com>
wrote:
>>>> Great work Mohammad!
>>>> Try it out and tell us if you need help!
>>>>
>>>> On Thu, Nov 17, 2011 at 8:15 AM, TARIQ <dontariq@gmail.com> wrote:
>>>>>
>>>>> Chukwa is working fine with Hadoop-0.20.2..Earlier I was using
>>>>> 0.20.203.0 and it had the same configuration just as 0.20.2..but it
>>>>> was not working earlier.I am able to start both agent and collector
>>>>> properly
>>>>>
>>>>> Regards,
>>>>>     Mohammad Tariq
>>>>>
>>>>>
>>>>>
>>>>> On Thu, Nov 17, 2011 at 9:55 AM, Eric Yang-3 [via Apache Chukwa]
>>>>> <[hidden email]> wrote:
>>>>> > Collector and agent share the same code for pid file locking.  You
may
>>>>> > want
>>>>> > to check $CHUKWA_HOME/conf/chukwa-env.sh on the collector machine
>>>>> > and make sure
>>>>> >
>>>>> > export CHUKWA_PID_DIR=
>>>>> >
>>>>> > is setup correctly.
>>>>> >
>>>>> > regards,
>>>>> > Eric
>>>>> >
>>>>> > On Wed, Nov 16, 2011 at 4:07 PM, Mohammad Tariq <[hidden email]>
wrote:
>>>>> >> Although I can find the Agent.pid file in pidDir directory,
the
>>>>> >> Collector.pid file is absent. And because of this the system
is not
>>>>> >> able to retrieve the PID of collector process.As a result kill
is also
>>>>> >> not working for collector.Any comments???
>>>>> >>
>>>>> >> Regards,
>>>>> >>     Mohammad Tariq
>>>>> >>
>>>>> >
>>>>> >
>>>>> > ________________________________
>>>>> > If you reply to this email, your message will be added to the discussion
>>>>> > below:
>>>>> >
>>>>> > http://apache-chukwa.679492.n3.nabble.com/No-Collector-pid-file-tp3514337p3514777.html
>>>>> > To unsubscribe from Apache Chukwa, click here.
>>>>> > NAML
>>>>>
>>>>> ________________________________
>>>>> View this message in context: Re: No Collector.pid file
>>>>> Sent from the Chukwa - Users mailing list archive at Nabble.com.
>>>>
>>>>
>>>>
>>>> --
>>>> Ahmed Fathalla
>>>>
>>>
>>
>

Mime
View raw message