incubator-chukwa-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ahmed Fathalla <afatha...@gmail.com>
Subject Re: No Collector.pid file
Date Thu, 17 Nov 2011 10:27:16 GMT
No, you don't...

Can you check what's listening on the port in question? I think you can use
the netstat command for this or something.

On Thu, Nov 17, 2011 at 12:16 PM, TARIQ <dontariq@gmail.com> wrote:

> I can see only one HICC instance running on my machine. Do I need
> jetty and tomcat running simultaneously on my machine???
>
> Regards,
>     Mohammad Tariq
>
>
>
> On Thu, Nov 17, 2011 at 2:21 PM, Eric Yang-3 [via Apache Chukwa]
> <[hidden email] <http://user/SendEmail.jtp?type=node&node=3515287&i=0>>
> wrote:
>
> > It looks like there is another instance of HICC running.
> >
> > regards,
> > Eric
> >
> > On Thu, Nov 17, 2011 at 12:24 AM, TARIQ <[hidden email]> wrote:
> >> 2011-11-17 12:16:54,464 INFO main ChukwaConfiguration - chukwaConf is
> >> /home/tariq/chukwa-0.4.0/bin/../conf
> >> 2011-11-17 12:16:54,696 INFO main HiccWebServer - Initializing HICC
> >> Datastore.
> >> 2011-11-17 12:16:57,292 INFO main HiccWebServer - HICC Datastore
> >> initialization completed.
> >> 2011-11-17 12:16:59,237 ERROR main HiccWebServer -
> >> java.net.BindException: Address already in use
> >>         at sun.nio.ch.Net.bind(Native Method)
> >>         at
> >>
> sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:126)
> >>         at
> >> sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:59)
> >>         at
> >>
> >>
> org.mortbay.jetty.nio.SelectChannelConnector.open(SelectChannelConnector.java:205)
>
> >>         at
> >>
> >>
> org.mortbay.jetty.nio.SelectChannelConnector.doStart(SelectChannelConnector.java:304)
>
> >>         at
> >>
> org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:39)
> >>         at org.mortbay.jetty.Server.doStart(Server.java:233)
> >>         at
> >>
> org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:39)
> >>         at
> >> org.apache.hadoop.chukwa.hicc.HiccWebServer.run(HiccWebServer.java:223)
> >>         at
> >>
> org.apache.hadoop.chukwa.hicc.HiccWebServer.start(HiccWebServer.java:93)
> >>         at
> >>
> org.apache.hadoop.chukwa.hicc.HiccWebServer.main(HiccWebServer.java:240)
> >>
> >> 2011-11-17 12:29:48,981 INFO main ChukwaConfiguration - chukwaConf is
> >> /home/tariq/chukwa-0.4.0/bin/../conf
> >> 2011-11-17 12:30:03,774 ERROR main HiccWebServer -
> >> java.net.BindException: Address already in use
> >>         at sun.nio.ch.Net.bind(Native Method)
> >>         at
> >>
> sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:126)
> >>         at
> >> sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:59)
> >>         at
> >>
> >>
> org.mortbay.jetty.nio.SelectChannelConnector.open(SelectChannelConnector.java:205)
>
> >>         at
> >>
> >>
> org.mortbay.jetty.nio.SelectChannelConnector.doStart(SelectChannelConnector.java:304)
>
> >>         at
> >>
> org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:39)
> >>         at org.mortbay.jetty.Server.doStart(Server.java:233)
> >>         at
> >>
> org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:39)
> >>         at
> >> org.apache.hadoop.chukwa.hicc.HiccWebServer.run(HiccWebServer.java:223)
> >>         at
> >>
> org.apache.hadoop.chukwa.hicc.HiccWebServer.start(HiccWebServer.java:93)
> >>         at
> >>
> org.apache.hadoop.chukwa.hicc.HiccWebServer.main(HiccWebServer.java:240)
> >>
> >> Regards,
> >>     Mohammad Tariq
> >>
> >>
> >>
> >> On Thu, Nov 17, 2011 at 1:48 PM, Eric Yang-3 [via Apache Chukwa]
> >> <[hidden email]> wrote:
> >>> What is the stack trace in the hicc.log?
> >>>
> >>> regards,
> >>> Eric
> >>>
> >>> On Wed, Nov 16, 2011 at 11:49 PM, Mohammad Tariq <[hidden email]>
> wrote:
> >>>> I have changed the collector port and now when I point my web browse
> >>>> to " <a href="<a
> >>>> href="<a href="http://localhost:8080/hicc/ ">
> http://localhost:8080/hicc/ "><a href="http://localhost:8080/hicc/ ">
> http://localhost:8080/hicc/ "><a
> >>>> href="<a href="http://localhost:8080/hicc/ ">
> http://localhost:8080/hicc/ "><a href="http://localhost:8080/hicc/ ">
> http://localhost:8080/hicc/ "
> >>>> it shows me -
> >>>>
> >>>> "HTTP Status 503 - This application is not currently available"
> >>>>
> >>>> The HiccWebServer is running/
> >>>>
> >>>> Regards,
> >>>>     Mohammad Tariq
> >>>>
> >>>>
> >>>>
> >>>> On Thu, Nov 17, 2011 at 12:45 PM, Mohammad Tariq <[hidden email]>
> wrote:
> >>>>> Hi Eric,
> >>>>>  Thanks a lot for the info.
> >>>>>
> >>>>> Regards,
> >>>>>     Mohammad Tariq
> >>>>>
> >>>>>
> >>>>>
> >>>>> On Thu, Nov 17, 2011 at 12:44 PM, Eric Yang <[hidden email]>
wrote:
> >>>>>> Hi Tariq,
> >>>>>>
> >>>>>> Chukwa hicc and collector are designed to run on different servers.
> >>>>>> Hence, it is probably best to use alternative port for Chukwa
> >>>>>> collector.  The port number for Chukwa collector can be adjusted
in
> >>>>>> chukwa-collector-conf.xml with chukwaCollector.http.port setting.
> >>>>>> "collectors" file should contain <a
> >>>>>> href="<a
> >>>>>> href="<a href="http://localhost:8090/ for">http://localhost:8090/
for"><a
> href="http://localhost:8090/ for">http://localhost:8090/ for"><a
> >>>>>> href="<a href="http://localhost:8090/ for agent">
> http://localhost:8090/ for agent"><a href="http://localhost:8090/
>  for agent to">http://localhost:8090/ for agent to
>
> >>>>>> push events to collector.
> >>>>>>
> >>>>>> regards,
> >>>>>> Eric
> >>>>>>
> >>>>>> On Wed, Nov 16, 2011 at 11:04 PM, Mohammad Tariq <[hidden
email]>
> >>>>>> wrote:
> >>>>>>> Hi Ahmed,
> >>>>>>>
> >>>>>>>   When I am pointing my web browser to " <a
> >>>>>>> href="<a
> >>>>>>> href="<a href="http://localhost:8080/hicc ">
> http://localhost:8080/hicc "><a href="http://localhost:8080/hicc ">
> http://localhost:8080/hicc "><a
> >>>>>>> href="<a href="http://localhost:8080/hicc ">
> http://localhost:8080/hicc "><a href="http://localhost:8080/hicc ">
> http://localhost:8080/hicc "
> >>>>>>> the only thing which I can see on the browser is " Chukwa
servlet
> >>>>>>> running "..and in the logs it is showing that address 8080
is
> already
> >>>>>>> in use, although I have changed the tomcat port to 8090.I
am using
> >>>>>>> 0.4.0..What might be the cause???
> >>>>>>>
> >>>>>>> Regards,
> >>>>>>>     Mohammad Tariq
> >>>>>>>
> >>>>>>>
> >>>>>>>
> >>>>>>> On Thu, Nov 17, 2011 at 11:54 AM, Mohammad Tariq <[hidden
email]>
> >>>>>>> wrote:
> >>>>>>>> Hello Ahmed,
> >>>>>>>>
> >>>>>>>>   Sure, i'll try and contact you on the list if I face
any
> >>>>>>>> problem..Who else do I have when it comes to Chukwa...;)
> >>>>>>>>
> >>>>>>>> Regards,
> >>>>>>>>     Mohammad Tariq
> >>>>>>>>
> >>>>>>>>
> >>>>>>>>
> >>>>>>>> On Thu, Nov 17, 2011 at 11:50 AM, Ahmed Fathalla <[hidden
email]>
> >>>>>>>> wrote:
> >>>>>>>>> Great work Mohammad!
> >>>>>>>>> Try it out and tell us if you need help!
> >>>>>>>>>
> >>>>>>>>> On Thu, Nov 17, 2011 at 8:15 AM, TARIQ <[hidden
email]> wrote:
> >>>>>>>>>>
> >>>>>>>>>> Chukwa is working fine with Hadoop-0.20.2..Earlier
I was using
> >>>>>>>>>> 0.20.203.0 and it had the same configuration
just as
> 0.20.2..but
> >>>>>>>>>> it
> >>>>>>>>>> was not working earlier.I am able to start both
agent and
> >>>>>>>>>> collector
> >>>>>>>>>> properly
> >>>>>>>>>>
> >>>>>>>>>> Regards,
> >>>>>>>>>>     Mohammad Tariq
> >>>>>>>>>>
> >>>>>>>>>>
> >>>>>>>>>>
> >>>>>>>>>> On Thu, Nov 17, 2011 at 9:55 AM, Eric Yang-3
[via Apache
> Chukwa]
> >>>>>>>>>> <[hidden email]> wrote:
> >>>>>>>>>> > Collector and agent share the same code
for pid file locking.
> >>>>>>>>>> >  You
> >>>>>>>>>> > may
> >>>>>>>>>> > want
> >>>>>>>>>> > to check $CHUKWA_HOME/conf/chukwa-env.sh
on the collector
> >>>>>>>>>> > machine
> >>>>>>>>>> > and make sure
> >>>>>>>>>> >
> >>>>>>>>>> > export CHUKWA_PID_DIR=
> >>>>>>>>>> >
> >>>>>>>>>> > is setup correctly.
> >>>>>>>>>> >
> >>>>>>>>>> > regards,
> >>>>>>>>>> > Eric
> >>>>>>>>>> >
> >>>>>>>>>> > On Wed, Nov 16, 2011 at 4:07 PM, Mohammad
Tariq <[hidden
> email]>
> >>>>>>>>>> > wrote:
> >>>>>>>>>> >> Although I can find the Agent.pid file
in pidDir directory,
> the
> >>>>>>>>>> >> Collector.pid file is absent. And because
of this the system
> is
> >>>>>>>>>> >> not
> >>>>>>>>>> >> able to retrieve the PID of collector
process.As a result
> kill
> >>>>>>>>>> >> is
> >>>>>>>>>> >> also
> >>>>>>>>>> >> not working for collector.Any comments???
> >>>>>>>>>> >>
> >>>>>>>>>> >> Regards,
> >>>>>>>>>> >>     Mohammad Tariq
> >>>>>>>>>> >>
> >>>>>>>>>> >
> >>>>>>>>>> >
> >>>>>>>>>> > ________________________________
> >>>>>>>>>> > If you reply to this email, your message
will be added to the
> >>>>>>>>>> > discussion
> >>>>>>>>>> > below:
> >>>>>>>>>> >
> >>>>>>>>>> >
> >>>>>>>>>> >
> >>>>>>>>>> >
> >>>>>>>>>> >
> http://apache-chukwa.679492.n3.nabble.com/No-Collector-pid-file-tp3514337p3514777.html
> >>>>>>>>>> > To unsubscribe from Apache Chukwa, click
here.
> >>>>>>>>>> > NAML
> >>>>>>>>>>
> >>>>>>>>>> ________________________________
> >>>>>>>>>> View this message in context: Re: No Collector.pid
file
> >>>>>>>>>> Sent from the Chukwa - Users mailing list archive
at
> Nabble.com.
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>> --
> >>>>>>>>> Ahmed Fathalla
> >>>>>>>>>
> >>>>>>>>
> >>>>>>>
> >>>>>>
> >>>>>
> >>>>
> >>>
> >>>
> >>> ________________________________
> >>> If you reply to this email, your message will be added to the
> discussion
> >>> below:
> >>>
> >>>
> >>>
> http://apache-chukwa.679492.n3.nabble.com/No-Collector-pid-file-tp3514337p3515078.html
> >>> To unsubscribe from Apache Chukwa, click here.
> >>> NAML
> >>
> >> ________________________________
> >> View this message in context: Re: No Collector.pid file
> >> Sent from the Chukwa - Users mailing list archive at Nabble.com.
> >>
> >
> >
> > ________________________________
> > If you reply to this email, your message will be added to the discussion
> > below:
> >
> http://apache-chukwa.679492.n3.nabble.com/No-Collector-pid-file-tp3514337p3515138.html
>
> > To unsubscribe from Apache Chukwa, click here.
> > NAML
>
> ------------------------------
> View this message in context: Re: No Collector.pid file<http://apache-chukwa.679492.n3.nabble.com/No-Collector-pid-file-tp3514337p3515287.html>
> Sent from the Chukwa - Users mailing list archive<http://apache-chukwa.679492.n3.nabble.com/Chukwa-Users-f679490.html>at
Nabble.com.
>



-- 
Ahmed Fathalla

Mime
View raw message