incubator-chukwa-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Yang <eric...@gmail.com>
Subject Re: Problems in reloading the collectors
Date Wed, 22 Sep 2010 03:30:18 GMT
Hi Stuti,

This is a bug.  I filed
https://issues.apache.org/jira/browse/CHUKWA-523 to track this issue.
Thanks

regards,
Eric

On Tue, Sep 21, 2010 at 6:12 AM, Stuti Awasthi
<Stuti_Awasthi@persistent.co.in> wrote:
> Hi,
>
>
>
> I am stuck in this issue from quite some time, I need to reload the
> collectors dynamically but reloadcollectors command is not working as
> desired
>
>
>
> Please suggest
>
>
>
> From: Stuti Awasthi [mailto:Stuti_Awasthi@persistent.co.in]
> Sent: Thursday, September 16, 2010 11:50 AM
>
> To: chukwa-user@incubator.apache.org
> Subject: RE: Problems in reloading the collectors
>
>
>
> Yes, I have changed collectors file present in conf/collectors on agent
> side. I suppose this is the only file that needs to be changed
>
>
>
> From: Jerome Boulon [mailto:jboulon@netflix.com]
> Sent: Thursday, September 16, 2010 11:46 AM
> To: chukwa-user@incubator.apache.org
> Subject: Re: Problems in reloading the collectors
>
>
>
> Did you change the right collector list? In the right folder on agent side?
>
>  /Jerome
>
> On Sep 15, 2010, at 23:04, "Stuti Awasthi" <Stuti_Awasthi@persistent.co.in>
> wrote:
>
> Hi All,
>
>
>
> I was trying to modify the collector list dynamically through reloading the
> collectors on agent side . I am using chukwa0.4 version. As it is mentioned
> in “Chukwa Agent Setup Guide” that reloadcollectors will re-read list of
> collectors.
>
>
>
> Here what I am exactly doing :
>
>
>
> 1)      Start the agent with some “X” collectors.
>
> 2)      Update the conf/collectors file with “Y” collector entry and
> removing “X” collector entry.
>
> 3)      Doing telnet to port 9093
>
> 4)      Firing command “reloadcollectors”.
>
>
>
> After reloading the collectors I got the response as “OK reloadCollectors
> done”. But when I check my agents logs I find that agent is still trying to
> connect to old collector “X” and does not connect to new collector
>
>
>
> Do I need to do anything more to add collectors dynamically to agent side.
> Please suggest
>
>
>
>
>
> Thanks
>
> Stuti
>
> DISCLAIMER ========== This e-mail may contain privileged and confidential
> information which is the property of Persistent Systems Ltd. It is intended
> only for the use of the individual or entity to which it is addressed. If
> you are not the intended recipient, you are not authorized to read, retain,
> copy, print, distribute or use this message. If you have received this
> communication in error, please notify the sender and delete all copies of
> this message. Persistent Systems Ltd. does not accept any liability for
> virus infected mails.
>
> DISCLAIMER ========== This e-mail may contain privileged and confidential
> information which is the property of Persistent Systems Ltd. It is intended
> only for the use of the individual or entity to which it is addressed. If
> you are not the intended recipient, you are not authorized to read, retain,
> copy, print, distribute or use this message. If you have received this
> communication in error, please notify the sender and delete all copies of
> this message. Persistent Systems Ltd. does not accept any liability for
> virus infected mails.
>
> DISCLAIMER ========== This e-mail may contain privileged and confidential
> information which is the property of Persistent Systems Ltd. It is intended
> only for the use of the individual or entity to which it is addressed. If
> you are not the intended recipient, you are not authorized to read, retain,
> copy, print, distribute or use this message. If you have received this
> communication in error, please notify the sender and delete all copies of
> this message. Persistent Systems Ltd. does not accept any liability for
> virus infected mails.

Mime
View raw message