incubator-chukwa-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Yang <ey...@yahoo-inc.com>
Subject Re: Chukwa build issue (should read Chukwa collector issue)
Date Fri, 18 Dec 2009 03:12:19 GMT
You can try to send a kill -3 11135 and capture the output in
chukwa-chukwizzle-jettyCollector.sh-hadoopm102.sacpa.videoegg.com.out

It may provide more information for debug.  Ditto what Ari said, use
./bin/start-collector.sh is better, tools/init.d only works as
/etc/init.d/chukwa-collector, if you are building with "ant rpm" and
installed the RPM package.  I also notice the bash error that you should
create var/tmp in /usr/local/chukwa to avoid the bash errors.

Regards,
Eric


On 12/17/09 6:47 PM, "Joe Hammerman" <jhammerman@videoegg.com> wrote:

> Eric,
> 
> Thank you for the response! No I'm not running on an IPv6 network:
> 
> [root@hadoopm102.sacpa ~]# ifconfig -a
> eth0      Link encap:Ethernet  HWaddr 00:18:FE:71:E3:50
>           inet addr:10.1.75.12  Bcast:10.1.95.255  Mask:255.255.224.0
>           inet6 addr: fe80::218:feff:fe71:e350/64 Scope:Link
>           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>           RX packets:2217102 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:723565 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 txqueuelen:1000
>           RX bytes:641183690 (611.4 MiB)  TX bytes:142622303 (136.0 MiB)
>           Interrupt:169 Memory:f8000000-f8012100
> 
> eth1      Link encap:Ethernet  HWaddr 00:18:FE:71:E3:4E
>           BROADCAST MULTICAST  MTU:1500  Metric:1
>           RX packets:0 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 txqueuelen:1000
>           RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
>           Interrupt:177 Memory:fa000000-fa012100
> 
> lo        Link encap:Local Loopback
>           inet addr:127.0.0.1  Mask:255.0.0.0
>           inet6 addr: ::1/128 Scope:Host
>           UP LOOPBACK RUNNING  MTU:16436  Metric:1
>           RX packets:8737 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:8737 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 txqueuelen:0
>           RX bytes:20724963 (19.7 MiB)  TX bytes:20724963 (19.7 MiB)
> 
> sit0      Link encap:IPv6-in-IPv4
>           NOARP  MTU:1480  Metric:1
>           RX packets:0 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 txqueuelen:0
>           RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
> 
> I believe the capitalized 'C' was a result of Outlook's auto-capitalization.
> The filename is not capitalized on the filesystem.
> 
> -----Original Message-----
> From: Eric Yang [mailto:eyang@yahoo-inc.com]
> Sent: Thursday, December 17, 2009 6:42 PM
> To: chukwa-user@hadoop.apache.org
> Subject: Re: Chukwa build issue
> 
> Hi Joe,
> 
> Normally, it will say which port it runs on in the .out file.  Like this:
> 
> 2009-12-18 01:36:37.201::INFO:  Logging to STDERR via
> org.mortbay.log.StdErrLog
> 2009-12-18 01:36:37.232::INFO:  jetty-6.1.11
> 2009-12-18 01:36:37.528::INFO:  Started SelectChannelConnector@0.0.0.0:8080
> started Chukwa http collector on port 8080
> 
> Are you running on IPv6 network?  From your message,
> chukwa-collector-conf.xml is spelled Chukwa-collector.conf.xml.  Maybe it
> was a typo.
> 
> Regards,
> Eric
> 
> 
> On 12/17/09 6:11 PM, "Joe Hammerman" <jhammerman@videoegg.com> wrote:
> 
>> Hello all,
>>                 Trying to get a Chukwa 0.3.0 installation up and running for
>> our Hadoop (Hadoop hadoop-0.20.1+152 from Cloudera) logs here. I¹ve read all
>> the documentation, and the archives; I can¹t find anyone who seems to have
>> encountered my error before. I followed the instructions here for Collector
>> configuration: http://www.cs.berkeley.edu/~asrabkin/chukwa/admin.html. ant
>> test runs without any test failures.
>>  
>>                 The problem is that when I run tools/init.d/chukwa-collector
>> I
>> don¹t see the daemon listening on port 8080. Here is the output from the
>> program launch:
>>  
>> [root@hadoopm102.sacpa init.d]# ./chukwa-collector start
>> Starting chukwa-collector: /usr/local/chukwa/bin/chukwa-daemon.sh: line 110:
>> /usr/local/chukwa/bin/../var/tmp/cron.200912180201: No such file or directory
>> /usr/local/chukwa/bin/chukwa-daemon.sh: line 114:
>> /usr/local/chukwa/bin/../var/tmp/cron.200912180201: No such file or directory
>> /usr/local/chukwa/bin/chukwa-daemon.sh: line 121:
>> /usr/local/chukwa/bin/../var/tmp/cron.200912180201: No such file or directory
>> Registering watchdog..done
>> starting jettyCollector.sh, logging to
>> 
/var/chukwa/log/chukwa-chukwizzle-jettyCollector.sh-hadoopm102.sacpa.videoegg>>
.
>> com.out
>> 2009-12-18 02:01:15.677::INFO:  Logging to STDERR via
>> org.mortbay.log.StdErrLog
>> 2009-12-18 02:01:15.704::INFO:  jetty-6.1.11
>>  
>> I have attached output showing that Chukwa is configured according to the
>> documentation to file, in order to keep the thread clear of clutter.
>>  
>> Does anyone have troubleshooting suggestions?
>>  
>> Thanks in advance for any help!
>> 
> 


Mime
View raw message