incubator-chemistry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephan Klevenz (JIRA)" <j...@apache.org>
Subject [jira] Issue Comment Edited: (CMIS-200) PagingList refactor part 2
Date Wed, 05 May 2010 12:43:04 GMT

    [ https://issues.apache.org/jira/browse/CMIS-200?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12864315#action_12864315
] 

Stephan Klevenz edited comment on CMIS-200 at 5/5/10 8:42 AM:
--------------------------------------------------------------

Collapse ItemIterator and ItemIterable interface to one single interface using standard Iterator
interface.

      was (Author: klevenzs):
    Collapse ItemIterator and ItemIterable interface
  
> PagingList refactor part 2
> --------------------------
>
>                 Key: CMIS-200
>                 URL: https://issues.apache.org/jira/browse/CMIS-200
>             Project: Chemistry
>          Issue Type: Bug
>          Components: opencmis-client
>            Reporter: David Caruana
>            Assignee: Stephan Klevenz
>
> - rename PagingIterable to the chosen name :-)  - candidates: SkipIterable, ItemIterable,
...
> - removes "maxItems" from the service calls
> - adds maxItems to OperationContext
> - adds a getPage(int maxItems)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message