You might want to look at:

http://www.opensourceconnections.com/2013/08/31/building-the-perfect-cassandra-test-environment/


On Sat, Mar 22, 2014 at 4:38 PM, Brian Flad <bflad417@gmail.com> wrote:
Is there anything else running on the boxes? Can you show us the output of ps aux for the Cassandra process so we can see the -xmx, etc? JDK 7 may help, even if you cannot upgrade Cassandra yet (which I would really recommend since it moves items off-heap).


On Sat, Mar 22, 2014 at 4:01 PM, prem yadav <ipremyadav@gmail.com> wrote:
Upgrading is not possible right now. Any other suggestions guys?
I have already tried reducing the number of rpc threads. Also tried reducing the linux kernel overcommit.


On Sat, Mar 22, 2014 at 5:44 PM, Laing, Michael <michael.laing@nytimes.com> wrote:
I ran into the same problem some time ago.

Upgrading to Cassandra 2, jdk 1.7, and default parameters fixed it.

I think the jdk change was the key for my similarly small memory cluster.

ml



On Sat, Mar 22, 2014 at 1:36 PM, prem yadav <ipremyadav@gmail.com> wrote:
Michael, no memory constraints. System memory is 4 GB and Cassandra run on default. 


On Sat, Mar 22, 2014 at 5:32 PM, prem yadav <ipremyadav@gmail.com> wrote:
Its Oracle jdk 1.6.
Robert, any fix that you know of which went into 1.2.15 for this particular issue?


On Sat, Mar 22, 2014 at 4:50 PM, Robert Coli <rcoli@eventbrite.com> wrote:
On Sat, Mar 22, 2014 at 7:48 AM, prem yadav <ipremyadav@gmail.com> wrote:
But, the cassandra process keeps getting killed due to OOM. Cassandra version in use is 1.1.9.

Try using 1.2.15, instead?

=Rob
 







--