incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Popescu <al...@datastax.com>
Subject Re: DataStax Devcenter CQL3 version vs Cassandra vrs
Date Fri, 28 Mar 2014 18:42:02 GMT
DevCenter 1.0 is the Java driver 1.0 to connect to your cluster. This
version of the driver doesn't support C* 2.0 with its latest CQL version.
Now you'll still be able to connect to a C* 2.0 cluster, but your queries
will actually need to be compatible with C* 1.2 (basically none of the
new CQL features will work).

On the bright side, we're working on updating DevCenter to use the Java
driver 2.0 which supports both C* 1.2 and 2.0 (and their corresponding
CQL versions).



On Fri, Mar 28, 2014 at 10:41 AM, Philip G <guice666@gmail.com> wrote:

> Within DevCenter, I'm getting an error: [feature] is introduced in CQL
> 3.1.0, you're running CQL 3.0.5.
>
> This doesn't make sense as I'm using the absolute latest version of
> Cassandra (2.0.6); connecting through cqlsh shows it's using 3.1.1:
>
>     Connected to Test Cluster at localhost:9160.
>     [cqlsh 4.1.1 | Cassandra 2.0.6 | CQL spec 3.1.1 | Thrift protocol
> 19.39.0]
>     Use HELP for help.
>
> What can I do to make DevCenter understand it should be connecting using
> 3.1.1?
>
> ---
> Philip
> gp@gpcentre.net
> http://www.gpcentre.net/
>



-- 

:- a)


Alex Popescu
Sen. Product Manager @ DataStax
@al3xandru

Mime
View raw message