incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Colin <colpcl...@gmail.com>
Subject Re: (SOLVED) Installing Datastax Cassandra 1.2.15 Using Yum (Java Issue)
Date Fri, 28 Mar 2014 16:48:23 GMT
OpenJDK will crash under load whilst running Cassandra.  

--
Colin 
+1 320 221 9531

 

> On Mar 28, 2014, at 4:11 PM, Jon Forrest <jon.forrest@xoom.com> wrote:
> 
> In a previous message I described my guess at
> what was causing the Datastax Cassandra installation
> to require OpenJDK. Using the method I describe below,
> I'm now able to install the Datastax Cassandra rpm.
> Note that I have no idea (yet) whether Cassandra actually
> runs, but at least it installs.
> 
> There's a wonderful opensource program out there called
> rpmrebuild. It lets you examine and modify the metadata
> in an rpm, including the dependencies. So, I ran
> 
> rpmrebuild -e -p cassandra12-1.2.15-1.noarch.rpm
> 
> This puts me in an editor with the spec file loaded.
> I searched for 'java' and found the line
> 
> Requires:      java >= 1.6.0
> 
> I changed this line to
> 
> Requires:      jdk >= 1.6.0
> 
> I wrote out the file and exited the editor. This created
> /root/rpmbuild/RPMS/noarch/cassandra12-1.2.15-1.noarch.rpm
> which I put in a local yum repo. I was then able to install
> this using yum and I was able to start Cassandra. Problem solved!
> 
> Now I'm on to test whether this installation really works.
> 
> Jon Forrest
> 
> 
> 
> The information transmitted in this email is intended only for the person or entity to
which it is addressed, and may contain material confidential to Xoom Corporation, and/or its
subsidiary, buyindiaonline.com Inc. Any review, retransmission, dissemination or other use
of, or taking of any action in reliance upon, this information by persons or entities other
than the intended recipient(s) is prohibited. If you received this email in error, please
contact the sender and delete the material from your files.

Mime
View raw message