incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacob Rhoden <jacob.rho...@me.com>
Subject Re: Update cassandra from perl 5.8
Date Mon, 03 Feb 2014 12:00:57 GMT
Hi Paul,

I think some of the dependencies, like Snappy also require perl 5.10. If its not too difficult
to get it to work in perl 5.8 it would be very much appreciated. If its a lot of work I wouldn’t
want to waste your time, after all who still depends on perl 5.8? (:

(I can always resort to doing nightly dumps and transforms of the mysql database, but its
no where near as good as having real time cassandra updates)

Thanks!
Jacob

On 3 Feb 2014, at 10:43 pm, Paul LeoNerd Evans <leonerd@leonerd.org.uk> wrote:

> On Mon, 03 Feb 2014 19:44:47 +1100
> Jacob Rhoden <jacob.rhoden@me.com> wrote:
> 
>> We’ve got a legacy application on Perl 5.8, don’t want to upgrade the
>> server for fear of something breaking. However for redundancy, It
>> would be great if I could update the app so it writes to both the
>> existing database, and cassandra. The Perl drivers appear to require
>> perl 5.10+
>> 
>>    https://github.com/mkjellman/perlcassa
>>    https://metacpan.org/pod/Net::Async::CassandraCQL
> 
> I wrote this latter.
> 
>> Just thought I would ask the list in the off chance that someone
>> might know of an alternate way to solve this problem or shoehorn a
>> perl driver onto this server.
> 
> If you want that to work on 5.8 I'm sure I could give it a go.
> 
> -- 
> Paul "LeoNerd" Evans
> 
> leonerd@leonerd.org.uk
> ICQ# 4135350       |  Registered Linux# 179460
> http://www.leonerd.org.uk/


Mime
View raw message