incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John R. Frank" <...@mit.edu>
Subject datastax community ami -- broken? --- datastax-agent conflicts with opscenter-agent
Date Fri, 06 Dec 2013 13:16:19 GMT
Hi C* experts,

In the last 18hrs or so, I have been having trouble getting cassandra 
instances to launch using the datastax community AMI.  Has anyone else 
seen this?

The instance comes up but then cassandra fails to run.  The most 
informative error message that I've seen so far is in the obscenter agent 
install log (below) --- see especially this line:

 	datastax-agent conflicts with opscenter-agent

I have also attached the ami.log

I run into these issues when launching with either the browser page:
https://aws.amazon.com/amis/datastax-auto-clustering-ami-2-2

Or command line, like this:

ec2-run-instances ami-814ec2e8 -t m1.large --region us-east-1 --key buildbot -n $num_instances
-d "--clustername Foo --totalnodes $num_instances  --version community  --opscenter yes"


Is there a newer AMI?


Any advice?
jrf




Some agent installations failed:

- 10.6.133.241: Failure installing agent on 10.6.133.241.
Error output:
Unable to install the opscenter-agent package. Please check your apt-get 
configuration as well as the agent install log 
(/var/log/opscenter-agent/installer.log).

Standard output:
Removing old opscenter-agent files.
opscenter-agent: unrecognized service
Reading package lists...
Building dependency tree...
Reading state information...
0 upgraded, 0 newly installed, 0 to remove and 171 not upgraded.
Starting agent installation process for version 3.2.2
Reading package lists...
Building dependency tree...
Reading state information...
sysstat is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 171 not upgraded.
Selecting previously unselected package opscenter-agent.
dpkg: regarding .../opscenter-agent.deb containing opscenter-agent:
datastax-agent conflicts with opscenter-agent
opscenter-agent (version 3.2.2) is to be installed.
opscenter-agent provides opscenter-agent and is to be installed.
dpkg: error processing 
opscenter_agent_setup.vYRzL0Tevn/opscenter-agent.deb (--install):
conflicting packages - not installing opscenter-agent
Errors were encountered while processing:
opscenter_agent_setup.vYRzL0Tevn/opscenter-agent.deb
FAILURE: Unable to install the opscenter-agent package. Please check your 
apt-get configuration as well as the agent install log 
(/var/log/opscenter-agent/installer.log).

Exit code: 1

Mime
View raw message