incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joaquin Casares <joaq...@datastax.com>
Subject Re: datastax community ami -- broken? --- datastax-agent conflicts with opscenter-agent
Date Fri, 06 Dec 2013 21:14:39 GMT
Hello again John,

The AMI has been patched and tested for both DSE and C* and works for the
standard 3 node test. The new code has been pushed to the 2.4 branch so
launching a new set of instances will give you an updated AMI.

You should now have the newest version of OpsCenter installed, along with
the new DataStax Agents (that replace the OpsCenter Agents). Also, I've
patched the two bugs for the motd and for allowing the other nodes to join.

The issue came from a new release of nodetool that contained some
unexpected text that choked up the AMI code as it waited for nodes to come
online.

Let me know if you see any further issues.

Thanks,

Joaquin Casares
DataStax
Software Engineer in Test


<http://www.datastax.com/what-we-offer/products-services/training/virtual-training>


On Fri, Dec 6, 2013 at 2:02 PM, Joaquin Casares <joaquin@datastax.com>wrote:

> Hey John,
>
> Thanks for letting us know. I'm also seeing that the motd gets stuck, but
> if I ctrl-c during the message and try a `nodetool status` there doesn't
> appear to be an issue.
>
> I'm currently investigating why it's getting stuck. Are you seeing
> something similar?
>
> What happens if you try to run a `sudo service cassandra restart`? Could
> you send me your /var/log/cassandra/system.log if this still fails?
>
> Also, I realize now that the package name for the newest version of
> OpsCenter changed from opscenter-free to opscenter. I committed that change
> to our dev AMI and am testing it now. Once this change is made you will no
> longer have to install agents via OpsCenter since they should already be on
> the system. That being said, you won't hit the current OpsCenter/DataStax
> Agent version mismatch you've been hitting.
>
> Also, we currently only have one AMI. Each time an instance is launched
> the newest version of the code is pulled down from
> https://github.com/riptano/ComboAMI to ensure the code never gets stale
> and can easily keep up with DSE/C* releases as well as AMI code fixes.
>
> I'll reply again as soon as I figure out and patch this motd issue.
>
> Thanks,
>
> Joaquin Casares
> DataStax
> Software Engineer in Test
>
>
>
> <http://www.datastax.com/what-we-offer/products-services/training/virtual-training>
>
>
> On Fri, Dec 6, 2013 at 7:16 AM, John R. Frank <jrf@mit.edu> wrote:
>
>> Hi C* experts,
>>
>> In the last 18hrs or so, I have been having trouble getting cassandra
>> instances to launch using the datastax community AMI.  Has anyone else seen
>> this?
>>
>> The instance comes up but then cassandra fails to run.  The most
>> informative error message that I've seen so far is in the obscenter agent
>> install log (below) --- see especially this line:
>>
>>         datastax-agent conflicts with opscenter-agent
>>
>> I have also attached the ami.log
>>
>> I run into these issues when launching with either the browser page:
>> https://aws.amazon.com/amis/datastax-auto-clustering-ami-2-2
>>
>> Or command line, like this:
>>
>> ec2-run-instances ami-814ec2e8 -t m1.large --region us-east-1 --key
>> buildbot -n $num_instances -d "--clustername Foo --totalnodes
>> $num_instances  --version community  --opscenter yes"
>>
>>
>> Is there a newer AMI?
>>
>>
>> Any advice?
>> jrf
>>
>>
>>
>>
>> Some agent installations failed:
>>
>> - 10.6.133.241: Failure installing agent on 10.6.133.241.
>> Error output:
>> Unable to install the opscenter-agent package. Please check your apt-get
>> configuration as well as the agent install log (/var/log/opscenter-agent/
>> installer.log).
>>
>> Standard output:
>> Removing old opscenter-agent files.
>> opscenter-agent: unrecognized service
>> Reading package lists...
>> Building dependency tree...
>> Reading state information...
>> 0 upgraded, 0 newly installed, 0 to remove and 171 not upgraded.
>> Starting agent installation process for version 3.2.2
>> Reading package lists...
>> Building dependency tree...
>> Reading state information...
>> sysstat is already the newest version.
>> 0 upgraded, 0 newly installed, 0 to remove and 171 not upgraded.
>> Selecting previously unselected package opscenter-agent.
>> dpkg: regarding .../opscenter-agent.deb containing opscenter-agent:
>> datastax-agent conflicts with opscenter-agent
>> opscenter-agent (version 3.2.2) is to be installed.
>> opscenter-agent provides opscenter-agent and is to be installed.
>> dpkg: error processing opscenter_agent_setup.vYRzL0Tevn/opscenter-agent.deb
>> (--install):
>> conflicting packages - not installing opscenter-agent
>> Errors were encountered while processing:
>> opscenter_agent_setup.vYRzL0Tevn/opscenter-agent.deb
>> FAILURE: Unable to install the opscenter-agent package. Please check your
>> apt-get configuration as well as the agent install log
>> (/var/log/opscenter-agent/installer.log).
>>
>> Exit code: 1
>>
>
>

Mime
View raw message