incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Romain HARDOUIN <romain.hardo...@urssaf.fr>
Subject Re: Running cqlsh throws "No appropriate python interpreter found."
Date Wed, 06 Nov 2013 14:21:59 GMT
Since you're on RHEL 5, you have compiled Python (no package available, 
right?).
Have you configured Python to be built with zlib support: 
"--with-zlib=/usr/lib"?
If not, compiled it with zlib and then run:
python -c "import zlib" 
No error should appear.

Romain

erwin.karbasi@gmail.com a écrit sur 06/11/2013 11:42:35 :

> De : Erwin Karbasi <erwin@optinity.com>
> A : "user@cassandra.apache.org" <user@cassandra.apache.org>, 
> Date : 06/11/2013 11:43
> Objet : Re: Running cqlsh throws "No appropriate python interpreter 
found."
> Envoyé par : erwin.karbasi@gmail.com
> 
> Now I'm experiencing this:
> 
> [iwuser@erwin-lab2 bin]$ ./cqlsh
> 
> Python CQL driver not installed, or not on PYTHONPATH.
> You might try "easy_install cql".
> 
> Python: /usr/local/bin/python2.6
> Module load path: ['./../lib/thrift-python-internal-only-0.9.1.zip',
> './../lib/cql-internal-only-1.4.1.zip/cql-1.4.1', '/home/iwuser/dsc-
> cassandra-2.0.2/bin', '/usr/local/bin/python2.6', '/usr/local/lib/
> python26.zip', '/usr/local/lib/python2.6', '/usr/local/lib/python2.
> 6/plat-linux2', '/usr/local/lib/python2.6/lib-tk', '/usr/local/lib/
> python2.6/lib-old', '/usr/local/lib/python2.6/lib-dynload', '/usr/
> local/lib/python2.6/site-packages']
> 
> Error: can't decompress data; zlib not available

> Any idea?
> 
> Thanks,
> Erwin Karbasi
> AT&T, Senior Software Architect
> 

> On Wed, Nov 6, 2013 at 9:27 AM, Erwin Karbasi <erwin@optinity.com> 
wrote:
> Hello All,

> I have installed Cassandra Datastax community edition 2.2 and python
> 2.6 but when I run ./cqlsh I faced with the following error:
> "No appropriate python interpreter found."

> I know that the error indicates that I have incompatible Python 
> version but I've already installed Python 2.6 and as it seems cqlsh 
> still uses my old version and not the new 2.6 version.

> Any suggestion that shed some light would highly appreciated?

> My OS is Linux RHEL 5. 
> 
> Thanks in advance,
> Erwin Karbasi
> AT&T, Senior Software Architect
Mime
View raw message