incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aaron Morton <aa...@thelastpickle.com>
Subject Re: Not able to form a Cassandra cluster of two nodes in Windows?
Date Tue, 05 Nov 2013 07:19:38 GMT
> My First Node details are - 
> 
>     initial_token: 0
>     seeds: "10.0.0.4"  
>     listen_address: 10.0.0.4   #IP of Machine - A (Wireless LAN adapter Wireless Network
Connection)
>     rpc_address: 10.0.0.4
> 
> My Second Node details are - 
> 
>     initial_token: 0
>     seeds: "10.0.0.4"    
>     listen_address: 10.0.0.7   #IP of Machine - B (Wireless LAN adapter Wireless Network
Connection)
>     rpc_address: 10.0.0.7
> 

You cannot have two nodes with the same tokens, is there an error in the logs ? 

if you are just starting put the simple thing is delete all the data and restart the machines.


Hope that helps. 

-----------------
Aaron Morton
New Zealand
@aaronmorton

Co-Founder & Principal Consultant
Apache Cassandra Consulting
http://www.thelastpickle.com

On 2/11/2013, at 6:02 am, Techy Teck <comptechgeeky@gmail.com> wrote:

> In my case, both of my laptop are running Windows 7 64 bit.. Not sure what's the problem...
> 
> 
> On Fri, Nov 1, 2013 at 4:48 AM, Aaron Mintz <aaron.m.mintz@gmail.com> wrote:
> One issue I ran into that produced similar symptoms: if you have internode_compression
turned on without the proper snappy library available for your architecture (i had 64-bit
linux), starting up will fail to link the nodes. It'll also be silent unless you set a certain
class logging level to DEBUG, but it basically presented as if nodes would each form their
own single-machine ring
> 
> 
> On Fri, Nov 1, 2013 at 3:52 AM, Techy Teck <comptechgeeky@gmail.com> wrote:
> I am trying to setup two nodes of Cassandra cluster on my windows machine. Basically,
I have two windows machine. In both of my machine, I have installed Cassandra 1.2.11 from
Datastax. Now I was following this [tutorial](http://www.datastax.com/2012/01/how-to-setup-and-monitor-a-multi-node-cassandra-cluster-on-windows)
to setup two node Cassandra Cluster.
> 
> After installing Cassandra into those two machines, I stopped the services for the Cassandra
server, DataStax OpsCenter, and the DataStax OpsCenter agent in those two machines.. 
> 
> And then I started making changes in the yaml file - 
> 
> My First Node details are - 
> 
>     initial_token: 0
>     seeds: "10.0.0.4"  
>     listen_address: 10.0.0.4   #IP of Machine - A (Wireless LAN adapter Wireless Network
Connection)
>     rpc_address: 10.0.0.4
> 
> My Second Node details are - 
> 
>     initial_token: 0
>     seeds: "10.0.0.4"    
>     listen_address: 10.0.0.7   #IP of Machine - B (Wireless LAN adapter Wireless Network
Connection)
>     rpc_address: 10.0.0.7
>     
> Both of my serves gets started up properly after I start the services for server. But
they are not forming a cluster of two nodes somehow? Is there anything I am missing here?
> 
> Machine-A Nodetool Information-
> 
>     Datacenter: datacenter1
>     ==========
>     Replicas: 1
>     
>     Address   Rack        Status State   Load            Owns                Token
>     
>     
>     10.0.0.4  rack1       Up     Normal  212.1 KB        100.00%             5264744098649860606
> 
> Machine-B Nodetool Information-
> 
>     Starting NodeTool
>     
>     Datacenter: datacenter1
>     ==========
>     Replicas: 1
>     
>     Address   Rack        Status State   Load            Owns                Token
>     
>     
>     10.0.0.7  rack1       Up     Normal  68.46 KB        100.00%             407804996740764696
>     
> 
> 
> 


Mime
View raw message