incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jiri Horky <ho...@avast.com>
Subject Cassandra 1.2.9 -> 2.0.0 update can't
Date Tue, 05 Nov 2013 15:47:36 GMT
Hi,

I know it is "Not Supported and also Not Advised", but currently we have
half of our cassandra cluster on 1.2.9 and the other half on 2.0.0 as we
got stuck during upgrade. We know already that it was not very wise
decision but that's what we've got now.

I have basically two questions. First, it would really help us if there
was a way how to make request to newer cassandra work with data on older
cassandra. We get
Caused by: com.datastax.driver.core.exceptions.UnavailableException: Not
enough replica available for query at consistency ONE (1 required but
only 0 alive),

which is surely caused by the fact that the newer nodes see the older as
DOWN in nodetool ring. We "solve" this problem by connecting to the
older nodes which see the whole cluster as online but it would help us
deploying newer version of our application if could connect to 2.0.0 as
well.

Second, to avoid any future problems when upgrading, is there any
documentation on what is incompatible between 1.2.x line and 2.0.x, what
is not supposed to work together and what are the recommended steps? I
don't see any warning regarding incompatibility of the gossip (?)
protocol between 2.0.0 and 1.2.9 causing the described problem in the
official documentation "Changes impacting upgrade".

Thank you
Jiri Horky

Mime
View raw message