> Don't know why it doesn't include just the preferred Oracle JRE

Probably due to licence concerns.

Romain