incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Bailey <n...@datastax.com>
Subject Re: Opscenter 3.2.2 (?) jmx auth issues
Date Fri, 18 Oct 2013 16:58:32 GMT
Sven,

I've verified there is an issue with jmx authentication in the 3.2.2
release. Thanks for the bug report! Sorry it's giving you issues. The bug
should be fixed in the next release of OpsCenter.

Nick


On Wed, Oct 16, 2013 at 8:07 PM, Sven Stark <sven.stark@m-square.com.au>wrote:

> Hi guys,
>
> we have secured C* jmx with username/pw. We upgraded our Opscenter from
> 3.0.2 to 3.2.2 last week and noticed that the agents could not connect
> anymore
>
> ERROR [jmx-metrics-4] 2013-10-17 00:45:54,437 Error getting general metrics
> java.lang.SecurityException: Authentication failed! Credentials required
> at
> com.sun.jmx.remote.security.JMXPluggableAuthenticator.authenticationFailure(JMXPluggableAuthenticator.java:193)
>  at
> com.sun.jmx.remote.security.JMXPluggableAuthenticator.authenticate(JMXPluggableAuthenticator.java:145)
>
> even though the credentials were correctly in
> /etc/opscenter/clusters/foo-cluster.conf
>
> [jmx]
> username = secret
> password = verysecret
> port = 20001
>
> Checks with other jmx based tools (nodetool, jmxtrans) confirm that the
> jmx setup is correct.
>
> Downgrading Opscenter to 3.0.2 immediately resolved the issue. Could
> anybody confirm whether that's a known bug?
>
>
> Cheers,
> Sven
>

Mime
View raw message