incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sylvain Lebresne <sylv...@datastax.com>
Subject Re: java exception on starting cqlsh
Date Tue, 17 Sep 2013 06:41:59 GMT
Short answer: you'll need to pass something like --cqlversion="3.0.0" to
cqlsh.

Longer answer: when a CQL client connects (and cqlsh is one), it asks to
use a specific version of CQL. If it asked for a version that is newer than
what the server knows, you get the error message you have above. So what
the above means is that you've used cqlsh from C* 2.0 (that asks for CQL
3.1.0 which is the version of CQL as of C* 2.0.0) against a C* 1.2 node. In
other words, what that error mean is that you use cqlsh from C* 2.0 so
maybe you mean to use C* 2.0 features, like compare-and-swap for instance,
but the server you're contacting does not know that so it'll refuse.
Passing --cqlversion="3.0.0" is a simple way to skip the check (note that
it has *no* impact on the server outside of making the check happy).

--
Sylvain



On Tue, Sep 17, 2013 at 7:39 AM, Tim Dunphy <bluethundr@gmail.com> wrote:

> hey guys,
>
>  I'm getting this exception when I try to run cqlsh.
>
> [root@beta:/var/www/admin] #cqlsh beta.mydomain.com 9160
> Traceback (most recent call last):
>   File "/etc/alternatives/cassandrahome/bin/cqlsh", line 2027, in <module>
>     main(*read_options(sys.argv[1:], os.environ))
>   File "/etc/alternatives/cassandrahome/bin/cqlsh", line 2013, in main
>     display_float_precision=options.float_precision)
>   File "/etc/alternatives/cassandrahome/bin/cqlsh", line 477, in __init__
>     cql_version=cqlver, transport=transport)
>   File
> "/etc/alternatives/cassandrahome/bin/../lib/cql-internal-only-1.4.0.zip/cql-1.4.0/cql/connection.py",
> line 143, in connect
>   File
> "/etc/alternatives/cassandrahome/bin/../lib/cql-internal-only-1.4.0.zip/cql-1.4.0/cql/connection.py",
> line 59, in __init__
>   File
> "/etc/alternatives/cassandrahome/bin/../lib/cql-internal-only-1.4.0.zip/cql-1.4.0/cql/thrifteries.py",
> line 162, in establish_connection
>   File
> "/etc/alternatives/cassandrahome/bin/../lib/cql-internal-only-1.4.0.zip/cql-1.4.0/cql/thrifteries.py",
> line 165, in set_cql_version
>   File
> "/etc/alternatives/cassandrahome/bin/../lib/cql-internal-only-1.4.0.zip/cql-1.4.0/cql/cassandra/Cassandra.py",
> line 1983, in set_cql_version
>   File
> "/etc/alternatives/cassandrahome/bin/../lib/cql-internal-only-1.4.0.zip/cql-1.4.0/cql/cassandra/Cassandra.py",
> line 2004, in recv_set_cql_version
> cql.cassandra.ttypes.InvalidRequestException:
> InvalidRequestException(why='Provided version 3.1.0 is not supported by
> this server (supported: 2.0.0, 3.0.1)')
>
>
> How do I correct the problem?
>
> thanks
>
> --
> GPG me!!
>
> gpg --keyserver pool.sks-keyservers.net --recv-keys F186197B
>
>

Mime
View raw message