incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Sanda <john.sa...@gmail.com>
Subject Re: system.peers and decommissioned nodes
Date Wed, 04 Sep 2013 19:31:56 GMT
I did not see any errors during decommission. I have gone ahead though and
upgraded to 1.2.9.


On Wed, Sep 4, 2013 at 1:13 PM, Nate McCall <nate@thelastpickle.com> wrote:

> Did you get any exceptions on decommission? Does CASSANDRA-5857 sound
> related at all? (1.2.4 is a few revs behind now and there have been a few
> fixes there, so and upgrade might not hurt).
>
>
> On Tue, Aug 27, 2013 at 5:53 PM, John Sanda <john.sanda@gmail.com> wrote:
>
>> Forgot to mention before, the host_id column is null for one of the rows.
>> Running nodetool removenode on the other one failed. StorageService threw
>> an exception because it could not find the host id (of the decommissioned
>> node with the non-null host_id in system.peers).
>>
>>
>> On Tuesday, August 27, 2013, John Sanda wrote:
>>
>>> I had a 4 node cluster running C* 1.2.4. I am testing some client code
>>> for adding/removing nodes to/from the cluster. I decommissioned 3 nodes. I
>>> only have one node now; however, the system.peers table still has rows for
>>> two of the nodes that were decommissioned. nodetool status only reports the
>>> one remaining node.
>>>
>>> Will it be a problem still having those decommissioned nodes in
>>> system.peers? And if so, what should be done to resolve it?
>>>
>>> - John
>>>
>>
>>
>> --
>>
>> - John
>>
>
>


-- 

- John

Mime
View raw message