incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Keith Wright <>
Subject Re: Unable to bootstrap node
Date Tue, 06 Aug 2013 01:08:35 GMT
Yes we likely dropped and recreated tables.  If we stop the sending node, what will happen
to the bootstrapping node?

sankalp kohli <> wrote:

    The problem is that the node sending the stream is hitting this FileNotFound exception.
You need to restart this node and it should fix the problem.

Are you seeing lot of FileNotFoundExceptions? Did you do any schema change recently?


On Mon, Aug 5, 2013 at 5:39 PM, Keith Wright <<>>
Hi all,

   I have been trying to bootstrap a new node into my 7 node 1.2.4 C* cluster with Vnodes
RF3 with no luck.  It gets close to completing and then the streaming just stalls with  streaming
at 99% from 1 or 2 nodes.  Nodetool netstats shows the items that have yet to stream but the
logs on the new node do not show any errors.  I tried shutting down then node, clearing all
data/commit logs/caches, and re-boot strapping with no luck.  The nodes that are hanging sending
the data only have the error below but that's related to compactions (see below) although
it is one of the files that is waiting to be sent.  I tried nodetool scrub on the column family
with the missing item but got an error indicating it could not get a hard link.  Any ideas?
 We were able to bootstrap one of the new nodes with no issues but this other one has been
a real pain.  Note that when the new node is joining the cluster, it does not appear in nodetool
status.  Is that expected?

Thanks all, my next step is to try getting a new IP for this machine, my thought being that
the cluster doesn't like me continuing to attempt to bootstrap the node repeatedly each time
getting a new host id.

[kwright@lxpcas008 ~]$ nodetool netstats | grep rts-40301_feedProducts-ib-1-Data.db
   rts: /data/1/cassandra/data/rts/40301_feedProducts/rts-40301_feedProducts-ib-1-Data.db
sections=73 progress=0/1884669 - 0%

ERROR [ReadStage:427] 2013-08-05 23:23:29,294 (line 174) Exception in
thread Thread[ReadStage:427,5,main]
java.lang.RuntimeException: /data/1/cassandra/data/rts/40301_feedProducts/rts-40301_feedProducts-ib-1-Data.db
(No such file or directory)
        at org.apache.cassandra.db.columniterator.SSTableNamesIterator.createFileDataInput(
        at org.apache.cassandra.db.columniterator.SSTableNamesIterator.<init>(
        at org.apache.cassandra.db.filter.NamesQueryFilter.getSSTableColumnIterator(
        at org.apache.cassandra.db.filter.QueryFilter.getSSTableColumnIterator(
        at org.apache.cassandra.db.CollationController.collectTimeOrderedData(
        at org.apache.cassandra.db.CollationController.getTopLevelColumns(
        at org.apache.cassandra.db.ColumnFamilyStore.getTopLevelColumns(
        at org.apache.cassandra.db.ColumnFamilyStore.getColumnFamily(
        at org.apache.cassandra.db.ColumnFamilyStore.getColumnFamily(
        at org.apache.cassandra.db.Table.getRow(
        at org.apache.cassandra.db.SliceByNamesReadCommand.getRow(
        at org.apache.cassandra.db.ReadVerbHandler.doVerb(
        at java.util.concurrent.ThreadPoolExecutor.runWorker(
        at java.util.concurrent.ThreadPoolExecutor$
Caused by: /data/1/cassandra/data/rts/40301_feedProducts/rts-40301_feedProducts-ib-1-Data.db
(No such file or directory)
        at Method)
        ... 20 more

View raw message