incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Morgan Segalis <msega...@gmail.com>
Subject Lost everything after topology change
Date Mon, 12 Aug 2013 16:36:44 GMT
Hi everyone,

I'm coming to you because I'm quite in a pickle, and need to get the Cassandra database working
asap…

I tried to change the topology file and tried a node tool repair…

in cassandra-cli when I tried to list a column family, it tells me 

null
UnavailableException()
	at org.apache.cassandra.thrift.Cassandra$get_range_slices_result.read(Cassandra.java:12262)
	at org.apache.thrift.TServiceClient.receiveBase(TServiceClient.java:78)
	at org.apache.cassandra.thrift.Cassandra$Client.recv_get_range_slices(Cassandra.java:683)
	at org.apache.cassandra.thrift.Cassandra$Client.get_range_slices(Cassandra.java:667)
	at org.apache.cassandra.cli.CliClient.executeList(CliClient.java:1373)
	at org.apache.cassandra.cli.CliClient.executeCLIStatement(CliClient.java:264)
	at org.apache.cassandra.cli.CliMain.processStatementInteractive(CliMain.java:219)
	at org.apache.cassandra.cli.CliMain.main(CliMain.java:346)

I can't seems to find out why.


in /var/lib/cassandra, all database files seems to be good since they are of same size than
before…
They are not gone, that a good news… but what can I do in order to get them back ?

Thank you ! 
Mime
View raw message