incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Coli <rc...@eventbrite.com>
Subject Re: Upgrade path to 2.0
Date Tue, 13 Aug 2013 18:41:34 GMT
On Tue, Aug 13, 2013 at 11:25 AM, Randy Fradin <randy.fradin@gmail.com>wrote:

> According to the upgrade notes from NEWS.txt, under 2.0.0 it says:
>
>     - Upgrading is ONLY supported from Cassandra 1.2.9 or later. This
>       goes for sstable compatibility as well as network.  When
>       upgrading from an earlier release, upgrade to 1.2.9 first and
>       run upgradesstables before proceeding to 2.0.
>
> Can someone tell me what specifically makes 2.0.0 incompatible with
> versions before 1.2.9? I have a 1.0.* cluster which I am looking to
> upgrade to 1.2.*. Since it appears 1.2.9 is not even released yet
> should I be waiting to upgrade?
>

This is not the first time that NEWS.txt tells you something that raises
more questions than it answers. I continue to maintain that it would be
useful to link to JIRA ticket(s) which are the reason for instructions in
NEWS.txt.

That said, per driftx these are the two ~1.2.8 era tickets which mean you
should upgrade from 1.2.9 or later.

https://issues.apache.org/jira/browse/CASSANDRA-5696 : Upgrading to
cassandra-1.2 with a dead LEFT state from 1.1 causes problems
https://issues.apache.org/jira/browse/CASSANDRA-5845 : Don't pull schema
from higher major nodes; don't push schema to lower major nodes

Disclaimer : You probably don't want to upgrade a real cluster to 2.0
anytime in the next 5 or so months.

=Rob

Mime
View raw message