incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Cobley <a.e.cob...@dundee.ac.uk>
Subject Vnodes, adding a node ?
Date Wed, 14 Aug 2013 19:02:17 GMT
I have  small test cluster of 2 nodes.  I ran a stress test on it and with nodetool status
received the following:

/usr/local/bin/apache-cassandra-2.0.0-rc1/log $ ../bin/nodetool status
Datacenter: datacenter1
=======================
Status=Up/Down
|/ State=Normal/Leaving/Joining/Moving
--  Address       Load       Tokens  Owns (effective)  Host ID                           
   Rack
UN  192.168.0.11  141.13 MB  256     49.2%             4d281e2e-efd9-4abf-bb70-ebdf8e2b4fc3
 rack1
UN  192.168.0.10  145.59 MB  256     50.8%             7fc5795a-bd1b-4e42-88d6-024c5216a893
 rack1

I then added a third node with no machines writing to the system.  Using nodetool status I
got the following:

/usr/local/bin/apache-cassandra-2.0.0-rc1/log $ ../bin/nodetool status
Datacenter: datacenter1
=======================
Status=Up/Down
|/ State=Normal/Leaving/Joining/Moving
--  Address       Load       Tokens  Owns (effective)  Host ID                           
   Rack
UN  192.168.0.11  141.12 MB  256     32.2%             4d281e2e-efd9-4abf-bb70-ebdf8e2b4fc3
 rack1
UN  192.168.0.10  145.59 MB  256     35.3%             7fc5795a-bd1b-4e42-88d6-024c5216a893
 rack1
UN  192.168.0.12  111.9 KB   256     32.5%             e5e6d8bd-c652-4c18-8fa3-3d71471eee65
 rack1

Is this correct ?  I was under the impression that adding a node to an existing cluster would
distribute the load around the cluster. Am I perhaps missing a step or have a config error
perhaps ?


Ta
Andy


The University of Dundee is a registered Scottish Charity, No: SC015096


Mime
View raw message