incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hiller, Dean" <Dean.Hil...@nrel.gov>
Subject Re: cassandra 1.2.6 -> Start key's token sorts after end token
Date Tue, 23 Jul 2013 20:13:04 GMT
Perhaps try 0.20.2 as

 1.  The maven pom files have cassandra depending on 0.20.2
 2.  The 0.20.2 default was murmur and we had to change it to random partitioner or it wouldn't
work for us

Ie. I suspect they will change the pom file to a more recent version of hadoop at some point
but I wonder if test suites suck in 0.20.2 because the pom file points to that version….depends
on if they actually have tests for map/reduce which is probably a bit hard.

Dean

From: Marcelo Elias Del Valle <mvallebr@gmail.com<mailto:mvallebr@gmail.com>>
Reply-To: "user@cassandra.apache.org<mailto:user@cassandra.apache.org>" <user@cassandra.apache.org<mailto:user@cassandra.apache.org>>
Date: Tuesday, July 23, 2013 1:54 PM
To: "user@cassandra.apache.org<mailto:user@cassandra.apache.org>" <user@cassandra.apache.org<mailto:user@cassandra.apache.org>>
Subject: Re: cassandra 1.2.6 -> Start key's token sorts after end token

Dean,

    I am using hadoop 1.0.3.
    Indeed, using Cassandra 1.2.3 with Random partitioner, it worked. However, it's the only
reason for me to use randompartitioner, I really would like to move forward. Besides, I tried
to use Cassandra 1.2.6 with RandomPartitioner and I got problems when inserting data, even
stopping Cassandra, cleaning my entire data folder and then starting it again.
    I am also really curious to know if there is anyone else having these problems or if it
is just me...

Best regards,
Marcelo.


2013/7/23 Hiller, Dean <Dean.Hiller@nrel.gov<mailto:Dean.Hiller@nrel.gov>>
Out of curiosity, what version of hadoop are you using with cassandra?  I think we are trying
0.20.2 if I remember(I have to ask my guy working on it to be sure).  I do remember him saying
the cassandra maven dependency was odd in that it is in the older version and not a newer
hadoop version.

We are using RandomPartitioner though right now which I have personally used in the past with
success.  We are in the process of map/reducing to a cassandra with MurmurPartitioner  (our
real reason to map/reduce is some refactorings in our model though and we just thought we
would switch to murmur).

Has anyone else used map/reduce with murmur partitioner?

Dean

From: Marcelo Elias Del Valle <mvallebr@gmail.com<mailto:mvallebr@gmail.com><mailto:mvallebr@gmail.com<mailto:mvallebr@gmail.com>>>
Reply-To: "user@cassandra.apache.org<mailto:user@cassandra.apache.org><mailto:user@cassandra.apache.org<mailto:user@cassandra.apache.org>>"
<user@cassandra.apache.org<mailto:user@cassandra.apache.org><mailto:user@cassandra.apache.org<mailto:user@cassandra.apache.org>>>
Date: Monday, July 22, 2013 4:04 PM
To: "user@cassandra.apache.org<mailto:user@cassandra.apache.org><mailto:user@cassandra.apache.org<mailto:user@cassandra.apache.org>>"
<user@cassandra.apache.org<mailto:user@cassandra.apache.org><mailto:user@cassandra.apache.org<mailto:user@cassandra.apache.org>>>
Subject: cassandra 1.2.6 -> Start key's token sorts after end token

Hello,

    I am trying to figure what might be cause this error. I am using Cassandra 1.2.6 (tried
with 1.2.3 as well) and I am trying to read data from cassandra on hadoop using column family
input format. I also got the same error using pure astyanax on a test.
    I am using Murmur3Partitioner and I created the keyspace using Cassandra 1.2.6, there
is nothing from prior versions. I created the keyspace with SimpleStrategy and replication
factor 1.
    Here is the exception I am getting:
2013-07-22 21:53:05,824 WARN org.apache.hadoop.mapred.Child (main): Error running child
java.lang.RuntimeException: InvalidRequestException(why:Start key's token sorts after end
token)
at org.apache.cassandra.hadoop.ColumnFamilyRecordReader$WideRowIterator.maybeInit(ColumnFamilyRecordReader.java:453)
at org.apache.cassandra.hadoop.ColumnFamilyRecordReader$WideRowIterator.computeNext(ColumnFamilyRecordReader.java:459)
at org.apache.cassandra.hadoop.ColumnFamilyRecordReader$WideRowIterator.computeNext(ColumnFamilyRecordReader.java:406)
at com.google.common.collect.AbstractIterator.tryToComputeNext(AbstractIterator.java:143)
at com.google.common.collect.AbstractIterator.hasNext(AbstractIterator.java:138)
at org.apache.cassandra.hadoop.ColumnFamilyRecordReader.getProgress(ColumnFamilyRecordReader.java:103)
at org.apache.hadoop.mapred.MapTask$NewTrackingRecordReader.getProgress(MapTask.java:522)
at org.apache.hadoop.mapred.MapTask$NewTrackingRecordReader.nextKeyValue(MapTask.java:547)
at org.apache.hadoop.mapreduce.MapContext.nextKeyValue(MapContext.java:67)
at org.apache.hadoop.mapreduce.Mapper.run(Mapper.java:143)
at org.apache.hadoop.mapred.MapTask.runNewMapper(MapTask.java:771)
at org.apache.hadoop.mapred.MapTask.run(MapTask.java:375)
at org.apache.hadoop.mapred.Child$4.run(Child.java:255)
at java.security.AccessController.doPrivileged(Native Method)
at javax.security.auth.Subject.doAs(Subject.java:396)
at org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1132)
at org.apache.hadoop.mapred.Child.main(Child.java:249)
Caused by: InvalidRequestException(why:Start key's token sorts after end token)
at org.apache.cassandra.thrift.Cassandra$get_paged_slice_result.read(Cassandra.java:14168)
at org.apache.thrift.TServiceClient.receiveBase(TServiceClient.java:78)
at org.apache.cassandra.thrift.Cassandra$Client.recv_get_paged_slice(Cassandra.java:769)
at org.apache.cassandra.thrift.Cassandra$Client.get_paged_slice(Cassandra.java:753)
at org.apache.cassandra.hadoop.ColumnFamilyRecordReader$WideRowIterator.maybeInit(ColumnFamilyRecordReader.java:438)
... 16 more
2013-07-22 21:53:05,828 INFO org.apache.hadoop.mapred.Task (main): Runnning cleanup for the
task

     Any hint?

Best regards,
--
Marcelo Elias Del Valle
http://mvalle.com - @mvallebr



--
Marcelo Elias Del Valle
http://mvalle.com - @mvallebr

Mime
View raw message