incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Tyler <jaty...@yahoo-inc.com>
Subject Re: node tool ring displays 33.33% owns on 3 node cluster with replication
Date Thu, 11 Jul 2013 16:58:09 GMT
Thanks Rob!  I was able to confirm with getendpoints.

Cheers,

~Jason

From: Robert Coli <rcoli@eventbrite.com<mailto:rcoli@eventbrite.com>>
Reply-To: "user@cassandra.apache.org<mailto:user@cassandra.apache.org>" <user@cassandra.apache.org<mailto:user@cassandra.apache.org>>
Date: Wednesday, July 10, 2013 4:09 PM
To: "user@cassandra.apache.org<mailto:user@cassandra.apache.org>" <user@cassandra.apache.org<mailto:user@cassandra.apache.org>>
Cc: Francois Richard <frichard@yahoo-inc.com<mailto:frichard@yahoo-inc.com>>
Subject: Re: node tool ring displays 33.33% owns on 3 node cluster with replication

On Wed, Jul 10, 2013 at 4:04 PM, Jason Tyler <jatyler@yahoo-inc.com<mailto:jatyler@yahoo-inc.com>>
wrote:
Is this simply a display issue, or have I lost replication?

Almost certainly just a display issue. Do "nodetool -h localhost getendpoints <keyspace>
<columnfamily> 0", which will tell you the endpoints for the non-transformed key "0."
It should give you 3 endpoints. You could also do this test with a known existing key and
then go to those nodes and verify that they have that data on disk via sstable2json.

(FWIW, it is an odd display issue/bug if it is one. Because it has reverted to pre-1.1 behavior...)

=Rob

Mime
View raw message