incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Tyler <jaty...@yahoo-inc.com>
Subject node tool ring displays 33.33% owns on 3 node cluster with replication
Date Wed, 10 Jul 2013 23:04:15 GMT
Hello,

I recently upgraded cassandra from 1.1.9 to 1.2.6 on a three node cluster with {replication_factor
: 3}.

When I run nodetool's ring, I see 'Owns' now reports 33.33%.  Previously it reported 100.00%
on each node.  The following snapshots are from two different clusters, so please ignore the
Load diffs. I did verify {replication_factor : 3} on both clusters.


1.1.9-xobni1 'nodetool -h 127.0.0.1 -p 8080 ring':
------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Address         DC          Rack        Status State   Load            Effective-Ownership
Token
                                                                                         
 170141183460469231731687303715884105728
Xxx.xx.xx.00   16          96          Up     Normal  225.03 GB       100.00%            
56713727820156410577229101238628035242
Xxx.xx.xx.01   16          97          Up     Normal  226.43 GB       100.00%            
113427455640312821154458202477256070484
Xxx.xx.xx.02   16          97          Up     Normal  231.76 GB       100.00%            
170141183460469231731687303715884105728
------------------------------------------------------------------------------------------------------------------------------------------------------------------------


1.2.6-xobni1 'nodetool -h 127.0.0.1 -p 8080 ring':
------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Address        Rack        Status State   Load            Owns                Token
                                                                              170141183460469231731687303715884105728
Xxx.xx.xx.00   97          Up     Normal  453.94 GB       33.33%              56713727820156410577229101238628035242
Xxx.xx.xx.01   97          Up     Normal  565.87 GB       33.33%              113427455640312821154458202477256070484
Xxx.xx.xx.02   96          Up     Normal  523.53 GB       33.33%              170141183460469231731687303715884105728
------------------------------------------------------------------------------------------------------------------------------------------------------------------------


Is this simply a display issue, or have I lost replication?

Thanks for any info.


Cheers,

~Jason

Mime
View raw message