incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Langston, Jim" <Jim.Langs...@compuware.com>
Subject alter column family ?
Date Tue, 09 Jul 2013 17:08:40 GMT
Hi all,

I am trying to alter a column family to change gc_grace_seconds, and now,
any of the properties

The sequence:

use ks ;
alter table CF with gc_grace_seconds=864000 ;

When listing the CF, gc_grace_seconds is set to 0, after
running the CLI, gc_grace_seconds is still set to 0.

I tried change the comment property, but this did not
change either.

Using the same keyspace, I created another table
and executed both the gc_grace_seconds change and
the comments change. Both of these successfully changed.

I do not know why I cannot change the value on a table that
was created earlier. I have tried shutting down the other nodes
in the cluster and attempted to change just one of the nodes,
also, I tried to stop/start Cassandra on that node as well to
see if the change would take effect that way.

Is there a permission ?

Where are the property values kept?

Thanks,

Jim

Mime
View raw message