incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Coli <rc...@eventbrite.com>
Subject Re: Cassandra intermittant with query in 1.2.5...
Date Mon, 08 Jul 2013 21:08:28 GMT
On Sat, Jul 6, 2013 at 10:57 PM, Tony Anecito <adanecito@yahoo.com> wrote:

> I better understand the issue now with secondary index query and Cassadra
> 1.2.5. not returnng rows.
>
> I did some more testng of the issue mentioned below and discovered a very
> repeatable sequence and it is as follows:
>
> 1. Starting state query running with caching off for a Column Family with
> the query using the secondary index for te WHERE clause.
> 2, Set Column Family caching to ALL using Cassandra-CLI and update CQL.
> Cassandra-cli Describe shows column family caching set to ALL
> 3. Rerun query and it works.
> 4. Restart Cassandra and run query and no rows returned. Cassandra-cli
> Describe shows column family caching set to ALL
> 5. Set Column Family caching to NONE using Cassandra-cli and update CQL.
> Rerun query and no rows returned. Cassandra-cli Describe for column family
> shows caching set to NONE.
> 6. Restart Cassandra. Rerun query and it is working again. We are now back
> to the starting state.
>
> I hope someone can tell me why Cassandra is doing this. Is there someing I
> need to do so that when I set caching to ALL for my column table and I
> stop-start Cassandra the query still works?
>

If I were you, I would file a CASSANDRA JIRA at
http://issues.apache.orgwith the above reproduction path.

There have been others who have reported similarly missing data with
secondary indexes in 1.2 era, if you have discovered the repro path they
will no doubt appreciate you filing this JIRA. :D

=Rob

Mime
View raw message