incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tony Anecito <adanec...@yahoo.com>
Subject Intresting issue with getting Order By to work...
Date Wed, 17 Jul 2013 03:44:59 GMT
Hi All,

Well I got most everything working I wanted using Cassandra then discovered I needed to use
an Order By. I am using Cassandra 1.2.5.
The use of Order By requires Primary Key which appears to be only supported by by using CQL
and not Cassandra-cli. So I dropped my table created uisng CLI and used CQL and was able to
create a "Table". But when I went to insert data that worked fine on the cli created table
I now get an exception:
Error while inserting com.datastax.driver.core.exceptions.InvalidQueryException: Unknown identifier
type.

I read that thrift clients will not work with CQL created tables due to extra things created
by the CQL. If so how can I create Primary Keys and be supported by thrift based clients??

I will post to Datastax the same question but trying to understand how to resolve cli vs CQL
issue like this. Seems like Cassandra-cli should support creation of compound primary keys
or CQL should create tables readable by thrift based clients. Is there some meta column info
people should add?
Also CQL tables are not visible via cli.so I can not see details on what was created by CQL
and the cqlsh script has errors according to the latest Python windows program I tried.

Thanks,
-Tony
Mime
View raw message