incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "himanshu.joshi" <himanshu.jo...@orkash.com>
Subject New virtual node not starting
Date Wed, 05 Jun 2013 08:46:05 GMT
Hi,

     I have added a third node(virtual) to a previously existing two 
node test cluster(virtual). When I am starting the new node after doing 
changes in the configuration file, it is getting struck for hours every 
time showing the following logs:

..........................................................................................
.........................................................................................
  INFO 17:50:57,571 JOINING: Starting to bootstrap...
  INFO 17:50:57,927 Finished streaming session 
0b78bd70-cc48-11e2-a1d4-b5b04f1aa4dc from /192.168.1.110
  INFO 17:55:26,729 Compacting 
[SSTableReader(path='/hda1-1/cassandra/data/system/peers/system-peers-ib-4-Data.db'), 
SSTableReader(path='/hda1-1/cassandra/data/system/peers/system-peers-ib-1-Data.db'), 
SSTableReader(path='/hda1-1/cassandra/data/system/peers/system-peers-ib-3-Data.db'), 
SSTableReader(path='/hda1-1/cassandra/data/system/peers/system-peers-ib-2-Data.db')]
  INFO 17:55:26,877 Compacted 4 sstables to 
[/hda1-1/cassandra/data/system/peers/system-peers-ib-5,].  18,311 bytes 
to 17,815 (~97% of original) in 146ms = 0.116368MB/s.  6 total rows, 2 
unique.  Row merge counts were {1:0, 2:0, 3:2, 4:0, }
  INFO 21:50:24,926 Saved KeyCache (19 items) in 116 ms
  INFO 01:50:24,923 Saved KeyCache (19 items) in 112 ms
  INFO 05:50:24,927 Saved KeyCache (19 items) in 116 ms
  INFO 09:50:24,932 Saved KeyCache (19 items) in 120 ms


I am using Cassandra tarball version 1.2.3 on all nodes with  Simple 
Strategy, Replication Factor 2 and ByteOrderedPartitioner. The Java 
version is "1.6.0_27"

The steps I followed to add new virtual node are:

     -Unzipped the tarball version in the desired path.
     -Edited the cassandra.yaml 
file(cluster_name,listen_address,endpoint_snitch,num_tokens,seed_provider, 
paths for data and logs etc...).
     -Then started cassandra on this new node which got struck.


Output of ./nodetool netstats on this node is:

Mode: JOINING
Not sending any streams.
  Nothing streaming from /192.168.1.103
Pool Name                    Active   Pending      Completed
Commands                        n/a         0              3
Responses                       n/a         0           11105

and for other two nodes is:

Mode: NORMAL
Not sending any streams.
Not receiving any streams.
Pool Name                    Active   Pending      Completed
Commands                        n/a         0              0
Responses                       n/a         0          11319

Mode: NORMAL
  Nothing streaming to /192.168.0.224
Not receiving any streams.
Pool Name                    Active   Pending      Completed
Commands                        n/a         0              0
Responses                       n/a         0          11283


Am I doing something wrong in creating a new node?

-- 
Thanks & Regards,
Himanshu Joshi


Mime
View raw message