incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tamar Fraenkel <ta...@tok-media.com>
Subject Re: column with TTL of 10 seconds lives very long...
Date Fri, 24 May 2013 10:26:37 GMT
By "it is still there" I mean that when I do get request in Cassandra cli I
get the column, as well as when I try to read the column using Hector.
I don't think it is a matter of tombstone. I have the default
gc_grace_seconds and I run repair weekly (will run on Sunday).
Other columns for same CF expire as expected after their 10 seconds pass.

Thanks,
Tamar

*Tamar Fraenkel *
Senior Software Engineer, TOK Media

[image: Inline image 1]

tamar@tok-media.com
Tel:   +972 2 6409736
Mob:  +972 54 8356490
Fax:   +972 2 5612956




On Thu, May 23, 2013 at 11:20 PM, Robert Coli <rcoli@eventbrite.com> wrote:

> On Wed, May 22, 2013 at 11:32 PM, Tamar Fraenkel <tamar@tok-media.com>wrote:
>
>> I am using Hector HLockManagerImpl, which creates a keyspace named
>> HLockManagerImpl and CF HLocks.
>> For some reason I have a row with single column that should have expired
>> yesterday who is still there.
>> I tried deleting it using cli, but it is stuck...
>> Any ideas how to delete it?
>>
>
> "is still there" is sorta ambiguous. Do you mean that clients see it or
> that it is still in the (immutable) data file it was previously in?
>
> If the latter, what is gc_grace_seconds set to? Make sure it's set to a
> low value and then make sure that your TTL-expired key is compacted?
>
> =Rob
>

Mime
View raw message