incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hiller, Dean" <Dean.Hil...@nrel.gov>
Subject Re: no backwards compatibility for thrift in 1.2.2? (we get utter failure)
Date Mon, 04 Mar 2013 02:51:13 GMT
It was an issue for existing tables as in QA, I ran an upgrade from 1.1.4
with simple data and then after 1.2.2, could not access stuff, ended up
with timeouts.  After that I cleared everything and just started a 1.2.2
as I wanted to see if just a base install of 1.2.2 with no upgrade worked
which it did not.

Ie. The backwards compatibility does not seem to be working.

Any ideas on how I could even attempt to resolve this?  We really want to
get to LCS and rumor is it is much slower in 1.1.x than 1.2.x on some post
I read 
http://mail-archives.apache.org/mod_mbox/cassandra-user/201302.mbox/%3C87D9
68E5-56A0-4DA7-8676-BA90FF376761@yahoo.com%3E

Thanks,
Dean


On 3/3/13 7:39 PM, "Michael Kjellman" <mkjellman@barracuda.com> wrote:

>Dean,
>
>I think if you look back through previous mailing list items you'll find
>answers to this already but to summarize:
>
>Tables created prior to 1.2 will continue to work after upgrade. New
>tables created are not exposed by the Thrift API. It is up to client
>developers to upgrade the client to pull the required metadata for
>serialization and deserialization of the data from the System column
>family instead.
>
>I don't know Netflix's time table for an update to Astyanax but I'm sure
>they are working on it. Alternatively, you can also  use the Datastax java
>driver in your QA environment for now.
>
>If you only need to access existing column families this shouldn't be an
>issue
>
>On 3/3/13 6:31 PM, "Hiller, Dean" <Dean.Hiller@nrel.gov> wrote:
>
>>I remember huge discussions on backwards compatibility and we have a ton
>>of code using thrift(as do many people out there).  We happen to have a
>>startup bean for development that populates data in cassandra for us.  We
>>cleared out our QA completely(no data) and ran thisÅ .it turns out there
>>seems to be no backwards compatibility as it utterly fails.
>>
>>From astyanax point of view, we simply get this (when going back to
>>1.1.4, everything works fine.  I can go down the path of finding out
>>where backwards compatibility breaks but does this mean essentially
>>everyone has to rewrite their applications?  OR is there a list of
>>breaking changes that we can't do anymore?  Has anyone tried the latest
>>astyanax client with 1.2.2 version?
>>
>>An unexpected error occured caused by exception RuntimeException:
>>com.netflix.astyanax.connectionpool.exceptions.NoAvailableHostsException:
>>NoAvailableHostsException: [host=None(0.0.0.0):0, latency=0(0),
>>attempts=0]No hosts to borrow from
>>
>>Thanks,
>>Dean
>
>
>Copy, by Barracuda, helps you store, protect, and share all your amazing
>
>things. Start today: www.copy.com.


Mime
View raw message