incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Venturella <aventure...@gmail.com>
Subject Re: Datastax AMI with multipart user-data
Date Thu, 28 Mar 2013 23:00:51 GMT
Ok I got it figured out. It was because I was installing packages in the
clout config file under the packages: directive.

I just switched it out to be in runcmd, now I don't get any locking error
when it installs packages as runcmd does not execute till the end.



On Thu, Mar 28, 2013 at 1:18 PM, Adam Venturella <aventurella@gmail.com>wrote:

> So, it looks like it supports multipart user-data:
> Line 86 here:
> https://github.com/riptano/ComboAMI/blob/2.4/ds2_configure.py
>
>
> I make my multipart user data,
>
> text/plaintext
> text/cloud-config
>
> I need to do some configuration and hook the cluster up to my puppet
> master.
>
> The cluster get's configured with the config options from the plaintext
> portion, when I login I see:
>
> Cluster started with these options:
> --clustername myname --totalnodes 4 --version community
>
>
> So that gets there. Now after that I see this
>
> Waiting for nodetool...
> The cluster is now in it's finalization phase. This should only take a
> moment...
>
> ....
>
> ------------------------------------
> DataStax AMI for DataStax Enterprise
> and DataStax Community
> AMI version 2.4
> DataStax Community version 1.2.3-1
>
> ------------------------------------
>
> So all is well.. Then I get:
>
> These notices occurred during the startup of this instance:
> [ERROR] 03/28/13-19:51:26 sudo apt-get update:
> [ERROR] 03/28/13-19:51:26 sudo apt-get update:
> [ERROR] 03/28/13-19:51:26 sudo apt-get update:
> [ERROR] 03/28/13-19:51:26 sudo apt-get update:
> [ERROR] 03/28/13-19:51:26 sudo apt-get update:
> [ERROR] 03/28/13-19:51:26 sudo apt-get update:
> [ERROR] 03/28/13-19:51:26 sudo apt-get update:
> .....
> [ERROR] 03/28/13-19:51:37 sudo apt-get update:
>
>
> It looks like it's trying to run the cloud-config but it's getting
> blocked.  It does run portions of it. It adds my custom deb repo to the box
> for example, but it can't run all of it.  It's the same cloud-config I am
> using for other boxes that need hooking up to the puppetmaster, and it
> works on those just fine.
>
> To create the multipart config I used the  write-mime-multipart command
> that is provided on Ubuntu.
>
> Anyone else run into this?
>
>
>
>

Mime
View raw message