incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From amulya rattan <talk2amu...@gmail.com>
Subject Re: Cassandra cluster setup issue
Date Sat, 09 Mar 2013 07:34:39 GMT
I just saw that the "failed to connect to 'x.x.x.x:7199' : connection
refused" error for nodetool that I am facing used to exist earlier also,
case in point https://issues.apache.org/jira/browse/CASSANDRA-4494
I can see this problem resurfacing in Cassandra 1.1.9 on my system. I am
using RHEL 6.0 and 7199 can be seen bound by Cassandra upon netstat. When I
do "telnet x.x.x.x 7199", that works too.

Any pointers please.


2013/3/8 amulya rattan <talk2amulya@gmail.com>

> I have started cassandra on three nodes, however opscenter only shows two
> of them. The missing one is starting properly, with gossip and everything
> else showing no errors. It also has the other nodes as seeds in
> cassandra.yaml, so I am amazed why it doesn't show as part of the ring. I
> have tried restarting it a bunch of times but neither does it throw any
> error, nor it shows as part of the ring
>
> Another strange thing is that nodetool won't start on any of the nodes. It
> keeps throwing connection refused error. It's not the same usual error one
> faces that starts with "Error connection to remote JMX agent!". It simply
> says connection refused on x.x.x.x:7199. However, I can see the JMX port is
> bound by cassandra on 0.0.0.0. I can use cassandra-cli on 9160 and
> opscenter on 8888, but not jmx port. As last resort, I turned off firewall
> completely, but to no avail.
>
> I never faced any such errors setting cassandra cluster up in the past, so
> this is completely flabbergasting to me given that the port is bound and
> firewall is off.
>
> Anybody faced anything similar in the past? Or anybody knows how to solve
> it? All responses appreciated.
>
> ~Amulya
>

Mime
View raw message