incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From aaron morton <aa...@thelastpickle.com>
Subject Re: repair hangs
Date Mon, 18 Mar 2013 17:13:05 GMT
> /raid0/cassandra/data/OpsCenter/events_timeline/OpsCenter-events_timeline-hf-1-Data.db
> is not compatible with current version ib
> --
This can be fixed with a nodetool upgradesstables

Cheers

-----------------
Aaron Morton
Freelance Cassandra Consultant
New Zealand

@aaronmorton
http://www.thelastpickle.com

On 15/03/2013, at 2:20 PM, Dane Miller <dane@optimalsocial.com> wrote:

> On Thu, Mar 14, 2013 at 6:34 AM, aaron morton <aaron@thelastpickle.com> wrote:
>>> 1. is this a nodetool bug?  is there any way to propagate the
>>> java.io.IOException back to nodetool?
>> The repair continues to work even if nodetool fails, it's a server side thing.
>> 
>>> 2. network problems on EC2, I'm shocked!  are there recommended
>>> network settings for EC2?
>> Streaming does not put a timeout on the socket, in this case check the 10.82.233.59
>> node to see why the pipe broke.
> 
> Good catch.  There are indeed errors on node 10.82.233.59:
> 
> cassandra3:/var/log/cassandra# grep -A1 ERROR system.log
> ERROR [Thread-5571] 2013-03-11 23:38:12,554 CassandraDaemon.java (line
> 132) Exception in thread Thread[Thread-5571,5,main]
> java.lang.UnsupportedOperationException: SSTable
> /raid0/cassandra/data/OpsCenter/events_timeline/OpsCenter-events_timeline-hf-1-Data.db
> is not compatible with current version ib
> --
> ERROR [Thread-5572] 2013-03-11 23:38:12,692 CassandraDaemon.java (line
> 132) Exception in thread Thread[Thread-5572,5,main]
> java.lang.UnsupportedOperationException: SSTable
> /raid0/cassandra/data/OpsCenter/rollups60/OpsCenter-rollups60-hf-766-Data.db
> is not compatible with current version ib
> --
> ERROR [Thread-5612] 2013-03-11 23:39:55,931 CassandraDaemon.java (line
> 132) Exception in thread Thread[Thread-5612,5,main]
> java.lang.UnsupportedOperationException: SSTable
> /raid0/cassandra/data/OpsCenter/rollups300/OpsCenter-rollups300-hf-506-Data.db
> is not compatible with current version ib
> --
> 
> 
> This attempt to create a new cluster from backups of the original
> cluster has not been going well.  These errors lead me to believe I
> need to focus on repairing the original cluster first.
> 
> Dane


Mime
View raw message