incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From aaron morton <aa...@thelastpickle.com>
Subject Re: secondary index problem
Date Mon, 18 Mar 2013 17:18:31 GMT
Brett, 
	Do you have some steps to reproduce the problem ? If so please create a ticket on jira. 

Cheers

-----------------
Aaron Morton
Freelance Cassandra Consultant
New Zealand

@aaronmorton
http://www.thelastpickle.com

On 16/03/2013, at 11:40 AM, Janne Jalkanen <Janne.Jalkanen@ecyrd.com> wrote:

> 
> This could be either of the following bugs (which might be the same thing).  I get it
too every time I recycle a node on 1.1.10.
> 
> https://issues.apache.org/jira/browse/CASSANDRA-4973
> or
> https://issues.apache.org/jira/browse/CASSANDRA-4785
> 
> /Janne
> 
> On Mar 15, 2013, at 23:24 , Brett Tinling <btinling@lacunasystems.com> wrote:
> 
>> We have a CF with an indexed column 'type', but we get incomplete results when we
query that CF for all rows matching 'type'.  We can find the missing rows if we query by key.
>> 
>> * we are seeing this on a small, single node, 1.2.2 instance with few rows.
>> * we use thrift execute_cql_query, no CL is specified
>> * none of repair, restart, compact, scrub helped
>> 
>> Finally, nodetool rebuild_index fixed it.  
>> 
>> Is index rebuild something we need to do periodically?  How often?  Is there a way
to know when it needs to be done?  Do we have to run rebuild on all nodes?
>> 
>> We have not noticed this until 1.2
>> 
>> Regards,
>>  - Brett
>> 
>> 
>> 
>> 
>> 
>> 
> 


Mime
View raw message