I had this problem using a rather old version of Open JDK. I downloaded the Sun JDK and its working now.

Brian

On Feb 4, 2013, at 1:04 PM, Kumar, Anjani wrote:

Thank you Aaron! I uninstalled older version of Cassandra and then brought 1.2.1 version of apache Cassandra as per your mail below. However, I am receiving the following error while starting Cassandra.
xss =  -ea -javaagent:./../lib/jamm-0.2.5.jar -XX:+UseThreadPriorities -XX:ThreadPriorityPolicy=42 -Xms1005M -Xmx1005M -Xmn200M -XX:+HeapDumpOnOutOfMemoryError -Xss180k
 
 
Thanks,
Anjani
 
From: aaron morton [mailto:aaron@thelastpickle.com] 
Sent: Monday, February 04, 2013 11:34 AM
To: user@cassandra.apache.org
Subject: Re: cassandra cqlsh error
 
Grab 1.2.1, it's fixed there http://cassandra.apache.org/download/
 
Cheers
 
-----------------
Aaron Morton
Freelance Cassandra Developer
New Zealand
 
@aaronmorton
 
On 5/02/2013, at 4:37 AM, "Kumar, Anjani" <Anjani.Kumar@infogroup.com> wrote:


 
I am facing problem while trying to run cqlsh. Here is what I did:
 
1.       I brought the tar ball files for both 1.1.7 and 1.2.0 version.
2.       Unzipped and untarred it
3.       Started Cassandra
4.       And then tried starting cqlsh but I am getting the following error in both the versions:
Connection error: Invalid method name: ‘set_cql_version’
 
Before installing Datastax 1.1.7 and 1.2.0 cassandra, I had installed Cassandra through “sudo apt-get install Cassandra” on my ubuntu. Since it doesn’t have CQL support(at least I cant find it) so I thought of installing Datastax version of Cassandra but still no luck starting cqlsh so far. Any suggestion?
 
Thanks,
Anjani