incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kumar, Anjani" <>
Subject RE: cassandra cqlsh error
Date Mon, 04 Feb 2013 19:45:12 GMT
It looks like an error. Since I checked for “cassandra”  in ps –ef and didn’t see anything.

Anjani Kumar
Sr. Software Engineer

office: 402.836.3337<>

Powering Business Growth

Find us here:  Twitter<>  |  Facebook<>

From: Dave Brosius []
Sent: Monday, February 04, 2013 1:05 PM
Subject: RE: cassandra cqlsh error

xss =  -ea -javaagent:./../lib/jamm-0.2.5.jar -XX:+UseThreadPriorities -XX:ThreadPriorityPolicy=42
-Xms1005M -Xmx1005M -Xmn200M -XX:+HeapDumpOnOutOfMemoryError -Xss180k

That is not an error, that is just 'debugging' information output to the command line.

----- Original Message -----
From: &quo t;Kumar, Anjani" <<>>
Sent: Mon, February 4, 2013 13:04
Subject: RE: cassandra cqlsh error
Thank you Aaron! I uninstalled older version of Cassandra and then brought 1.2.1 version of
apache Cassandra as per your mail below. However, I am receiving the following error while
starting Cassandra.
xss =  -ea -javaagent:./../lib/jamm-0.2.5.jar -XX:+UseThreadPriorities -XX:ThreadPriorityPolicy=42
-Xms1005M -Xmx1005M -Xmn200M -XX:+HeapDumpOnOutOfMemoryError -Xss180k


From: aaron morton []
Sent: Monday, February 04, 2013 11:34 AM
Subject: Re: cassandra cqlsh error

Grab 1.2.1, it's fixed there


Aaron Morton
Freelance Cassandra Developer
New Zealand


On 5/02/2013, at 4:37 AM, "Kumar, Anjani" <<>>

I am facing problem while trying to run cqlsh. Here is what I did:

1.       I brought the tar ball files for both 1.1.7 and 1.2.0 version.
2.       Unzipped and untarred it
3.       Started Cassandra
4.       And then tried starti ng cqlsh but I am getting the following error in both the versions:
Connection error: Invalid method name: ‘set_cql_version’

Before installing Datastax 1.1.7 and 1.2.0 cassandra, I had installed Cassandra through “sudo
apt-get install Cassandra” on my ubuntu. Since it doesn’t have CQL support(at least I
cant find it) so I thought of installing Datastax version of Cassandra but still no luck starting
cqlsh so far. Any suggestion?


View raw message