incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Edward Capriolo <edlinuxg...@gmail.com>
Subject Re: Upgrade from 0.6.x to 1.2.x
Date Fri, 08 Feb 2013 13:37:46 GMT
We did this along time ago. Besides the upgrade, the issue is that the
thrift clients are completely incompatible between 0.6.x and 0.7.x
thus you will have to coordinate a software release with clients as
well as the Cassandra update.

On Fri, Feb 8, 2013 at 8:33 AM, Sergey Leschenko <sergle.ua@gmail.com> wrote:
> On Thu, Feb 7, 2013 at 9:07 PM, Bryan Talbot <btalbot@aeriagames.com> wrote:
>> Wow, that's pretty ambitions expecting an upgrade which skips 4 major
>> versions (0.7, 0.8, 1.0, 1.1) to work.
>
> It seems to work after all, at least data saved in 0.6.x is accessible
> via 1.2.1 version on my test installation.
>
>> I think you're going to have to follow the upgrade path for each of those
>> intermediate steps and not upgrade in one big jump.
>
> It's a question of downtime and complexity of upgrade procedure, which
> have to be scripted (automated) in my case.
> And I'm trying to make it as simple as possible.
>
> --
> Sergey

Mime
View raw message