incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Boris Solovyov <boris.solov...@gmail.com>
Subject Re: Nodetool doesn't shows two nodes
Date Sun, 17 Feb 2013 21:56:10 GMT
No, it doesn't works, same thing: both nodes seems to just exist solo and I
have 2 single-node clusters :-( OK, so now I am confused, and hope list
will help me out. To understand what wrong, I think I need to know what
happens in node bootstrap, and in node join ring. Who does node
communicate, on which address? What information it exchanges? What happens
then? What this process looks like normally?

I have read all docs, several time, don't think I missed it, so it might
not be explain there clearly. I will look again, and look to source code
next.

- Boris


On Sun, Feb 17, 2013 at 4:48 PM, Boris Solovyov <boris.solovyov@gmail.com>wrote:

> Aha! I think I might have something breakthrough. I tried setting public
> IP in listen_address (and therefore in broadcast_address, because as I
> understand it inherits if it is commented out), and in seeds list.  Node
> fails to start, because Cassandra cannot bind to public IP address: it does
> not exists on box. Of course! This is why I cannot see it in ifconfig.
>
> SO, my next theory,
>
>    - set listen_address to private IP
>    - set broadcast_address to public IP, tells other nodes how to connect
>    - set seeds to public IP
>
> I will try this next and continue flood your inbox with stream of
> consciousness try-and-error ;-)
>

Mime
View raw message