incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Qiaobing Xie <qiaobing....@gmail.com>
Subject Re: thrift client can't add a column back after it was deleted with cassandra-cli?
Date Sat, 22 Dec 2012 05:16:31 GMT
That makes sense - I think my client uses milliseconds. Thanks for 
pointing that out.

-Q

On 12/21/12 6:25 PM, Edward Capriolo wrote:
> The cli using microsecond precision your client might be using 
> something else and the insert with lower timestamps are dropped.
>
> On Friday, December 21, 2012, Qiaobing Xie <qiaobing.xie@gmail.com 
> <mailto:qiaobing.xie@gmail.com>> wrote:
> > Hi,
> >
> > I am developing a thrift client that inserts and removes columns 
> from a column-family (using batch_mutate calls). Everything seems to 
> be working fine - my thrift client can add/retrieve/delete/add back 
> columns as expected... until I manually deleted a column with 
> cassandra-cli. (I was trying to test an error scenario in which my 
> client would discover a missing column and recreated it in the 
> column-family). After I deleted a column from within cassandra-cli 
> manually, my thrift client detected the column of that name missing 
> when it tried to get it. So it tried to recreated a new column with 
> that name along with a bunch of other columns with a batch_mutate 
> call. The call returned normally and the other columns were 
> added/updated, but the one that I manually deleted from cassandra-cli 
> was not added/created in the column family.
> >
> > I tried to restart my client and cassandra-cli but it didn't help. 
> It just seemed that my thrift client could no longer add a column with 
> that name! Finally I destroyed and recreated the whole column-family 
> and the problem went away.
> >
> > Any idea what I did wrong?
> >
> > -Qiaobing
> >
> >
> > 


Mime
View raw message