incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Qiaobing Xie <qiaobing....@gmail.com>
Subject thrift client can't add a column back after it was deleted with cassandra-cli?
Date Fri, 21 Dec 2012 22:01:41 GMT
Hi,

I am developing a thrift client that inserts and removes columns from a 
column-family (using batch_mutate calls). Everything seems to be working 
fine - my thrift client can add/retrieve/delete/add back columns as 
expected... until I manually deleted a column with cassandra-cli. (I was 
trying to test an error scenario in which my client would discover a 
missing column and recreated it in the column-family). After I deleted a 
column from within cassandra-cli manually, my thrift client detected the 
column of that name missing when it tried to get it. So it tried to 
recreated a new column with that name along with a bunch of other 
columns with a batch_mutate call. The call returned normally and the 
other columns were added/updated, but the one that I manually deleted 
from cassandra-cli was not added/created in the column family.

I tried to restart my client and cassandra-cli but it didn't help. It 
just seemed that my thrift client could no longer add a column with that 
name! Finally I destroyed and recreated the whole column-family and the 
problem went away.

Any idea what I did wrong?

-Qiaobing



Mime
View raw message