Hi
A bit more info on that
I have one working setup with
python-cql    1.0.9-1
python-thrift  0.6.0-2~riptano1
cassandra    1.0.8

The setup where cqlsh is not working has:
python-cql    1.0.10-1
python-thrift  0.6.0-2~riptano1
cassandra    1.0.11

Maybe this will give someone a hint of what the problem may be and how to solve it.
Thanks!

Tamar Fraenkel 
Senior Software Engineer, TOK Media 

Inline image 1

tamar@tok-media.com
Tel:   +972 2 6409736 
Mob:  +972 54 8356490 
Fax:   +972 2 5612956 





On Thu, Nov 8, 2012 at 9:38 AM, Tamar Fraenkel <tamar@tok-media.com> wrote:
Nope...
Same error:

cqlsh --debug --cql3 localhost 9160

Using CQL driver: <module 'cql' from '/usr/lib/pymodules/python2.6/cql/__init__.pyc'>
Using thrift lib: <module 'thrift' from '/usr/lib/pymodules/python2.6/thrift/__init__.pyc'>
Connection error: Invalid method name: 'set_cql_version'


I believe it is some version mismatch. But this was DataStax AMI, I thought all should be coordinated, and I am not sure what to check for.


Thanks,

Tamar Fraenkel 
Senior Software Engineer, TOK Media 






On Thu, Nov 8, 2012 at 4:56 AM, Jason Wee <peichieh@gmail.com> wrote:
should it be --cql3 ?
http://www.datastax.com/docs/1.1/dml/using_cql#start-cql3



On Wed, Nov 7, 2012 at 11:16 PM, Tamar Fraenkel <tamar@tok-media.com> wrote:
Hi!
I installed new cluster using DataStax AMI with --release 1.0.11, so I have cassandra 1.0.11 installed.
Nodes have python-cql 1.0.10-1 and python2.6

Cluster works well, BUT when I try to connect to the cqlsh I get:
cqlsh --debug --cqlversion=2 localhost 9160
Using CQL driver: <module 'cql' from '/usr/lib/pymodules/python2.6/cql/__init__.pyc'>
Using thrift lib: <module 'thrift' from '/usr/lib/pymodules/python2.6/thrift/__init__.pyc'>
Connection error: Invalid method name: 'set_cql_version'

This is the same if I chose cqlversion=3

Any idea how to solve?

Thanks,

Tamar Fraenkel 

Senior Software Engineer, TOK Media