incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Everton Lima <peitin.inu...@gmail.com>
Subject SchemaDisagreementException
Date Wed, 14 Nov 2012 14:13:30 GMT
Some times, when I try to insert a data in Cassandra with Method:

static void createColumnFamily(String keySpace, String columnFamily){
 synchronized (mutex){
  Iface cs = new CassandraServer();
  CfDef cfDef = new CfDef(keySpace, columnFamily);

  cfDef = cfDef.setComparator_type(comparator.toString());
  cfDef = cfDef.setKey_validation_class(UTF8Type.class.getName());
  cfDef = cfDef.setCaching("all");

  cs.set_keyspace(keySpace);
  cs.system_add_column_family(cfDef);
 }
}

I run this method in only on process of the distributor system. But in this
process, I run the method two times consecutive in the same thread, but
with keyspace diferent.
I already read in the documentation that this error occurs when more than
one thread/processor access the same place in the Cassandra, but I think
this is not occuring.
Some one cold help me to understand this problem?

Thanks.

-- 

Everton Lima Aleixo
Bacharel em Ciencia da Computação
Universidade Federal de Goiás

Mime
View raw message