incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From aaron morton <aa...@thelastpickle.com>
Subject Re: a node stays in joining
Date Wed, 26 Sep 2012 21:21:08 GMT
> 
> But the Load keeps on increasing.

Sounds like the nodes are / were sending it data. 

nodetool netstats will show you what's going on. 

Cheers

-----------------
Aaron Morton
Freelance Developer
@aaronmorton
http://www.thelastpickle.com

On 25/09/2012, at 10:22 PM, Satoshi Yamada <bigtvioletblue@yahoo.co.jp> wrote:

> 
> hi,
> 
> One node in my cluster stay in "joining". I found a jira about this, which is fixed,
> but still sees the similar thing. This is a node I remove the token first because
> it did not boot correctly and re-joined in the cluster without any pre-set token(should
> I set the previous token?).
> 
> As you see below, the node(yyyy)'s state is Joining and Effective-Ownership is 0.00 %
> for more than 10 hours. But the Load keeps on increasing.
> 
> Also I noticed in the gossipinfo, the status of the node is BOOT while other node is

> NORMAL.
> 
> So, how can I get the status of the node to NORMAL?
> 
> $ nodetool -h `hostname` ring
> Address            DC       Rack            Status      Load        State      Load 
    Effe...
> xxxx       datacenter1     rack1           Up             Normal   122.41 MB        4.27
%
> .....
> ....
> yyyy      datacenter1     rack1           Up            Joining        371.33 MB    0.00
%
> 
> 
> $ nodetool -h `hostname` gossipinfo
> ....
> ....
> yyyy/192.0.1.111
>    RELEASE=VERSION:1.1.4
>    LOAD:3.89343423E8
>    STATUS:BOOT, 123123123....1312.
>    SCHEMA:a442323-......
> 
> thanks,
> satoshi


Mime
View raw message