whoops! sorry about that! trying again..

[default@unknown] connect beta.jokefire.com/9160;
Connected to: "Test Cluster" on beta.jokefire.com/9160

[default@unknown] use system;
Authenticated to keyspace: system
[default@system] set LocationInfo[utf8('L')][utf8('Cluster Name')]=utf8('Jokefire Cluster'
);
Value inserted.
Elapsed time: 38 msec(s).

[default@system] exit;
[root@beta:~] #nodetool -h beta.jokefire.com flush


[root@beta:~] #grep cluster_name /etc/alternatives/cassandrahome/conf/cassandra.yaml
cluster_name: 'Jokefire Cluster'

And I still get the same result:

ERROR 12:02:24,023 Fatal exception during initialization
org.apache.cassandra.config.ConfigurationException: Saved cluster name Test Cluster != configured name Jokefire Cluster
        at org.apache.cassandra.db.SystemTable.checkHealth(SystemTable.java:299)
        at org.apache.cassandra.service.AbstractCassandraDaemon.setup(AbstractCassandraDaemon.java:169)
        at org.apache.cassandra.service.AbstractCassandraDaemon.activate(AbstractCassandraDaemon.java:356)
        at org.apache.cassandra.thrift.CassandraDaemon.main(CassandraDaemon.java:107)


And just making sure this is clear, DNS appears to be fine:

[root@beta:~] #grep beta /etc/hosts
198.101.216.47  beta.jokefire.com beta

[root@beta:~] #host beta.jokefire.com
beta.jokefire.com has address 198.101.216.47

thanks I appreciate the advice you've been giving me... hope I can get this to work!

On Wed, Aug 8, 2012 at 11:49 AM, Abhijit Chanda <abhijit.chanda0@gmail.com> wrote:
If you have used the above commands then i guess problem lies in this step.

[default@system] set LocationInfo[utf8('L')][utf8('Test Cluster')]=utf8('Jokefire Cluster');

It should be like this:  set LocationInfo[utf8('L')][utf8('Cluster Name')]=utf8('Jokefire Cluster');





--
GPG me!!

gpg --keyserver pool.sks-keyservers.net --recv-keys F186197B