cassandra.yaml on all nodes had ByteOrderedPartitioner with both the previous version and upgraded version.

That being said, when I first started up cassandra after upgrading  (with the updated .yaml, including ByteOrderedPartitioner) all nodes in the ring appeared to be up.  But the load they carried was minimal (KB, as opposed to GB in the previous version), and the keyspace didn't exist.  Then when I attempted to restart the daemon on each to see if it would help, but starting up failed on each with the partition error.

Casey

On Tue, May 15, 2012 at 12:59 PM, Oleg Dulin <oleg.dulin@liquidanalytics.com> wrote:
Did you check cassandra.yaml to make sure partitioner there matches what was in your old cluster ?

Regards,
Oleg Dulin
Please note my new office #: 732-917-0159

On May 15, 2012, at 3:22 PM, Casey Deccio wrote:

Here's something new in the logs:

ERROR 12:21:09,418 Exception in thread Thread[SSTableBatchOpen:2,5,main]
java.lang.RuntimeException: Cannot open /var/lib/cassandra/data/system/Versions/system-Versions-hc-35 because partitioner does not match org.apache.cassandra.dht.ByteOrderedPartitioner
        at org.apache.cassandra.io.sstable.SSTableReader.open(SSTableReader.java:164)
        at org.apache.cassandra.io.sstable.SSTableReader$1.run(SSTableReader.java:224)
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
        at java.util.concurrent.FutureTask.run(FutureTask.java:138)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
        at java.lang.Thread.run(Thread.java:662)

Casey

On Tue, May 15, 2012 at 12:08 PM, Casey Deccio <casey@deccio.net> wrote:
I recently upgraded from cassandra 1.0.10 to 1.1.  Everything worked fine in one environment, but after I upgraded in another, I can't find my keyspace.  When I run, e.g., cassandra-cli with 'use KeySpace;' It tells me that the keyspace doesn't exist.  In the log I see this:

ERROR [MigrationStage:1] 2012-05-15 11:39:48,216 AbstractCassandraDaemon.java (line 134) Exception in thread Thread[MigrationStage:1,5,main]java.lang.AssertionError
        at org.apache.cassandra.db.DefsTable.updateKeyspace(DefsTable.java:441)
        at org.apache.cassandra.db.DefsTable.mergeKeyspaces(DefsTable.java:339)
        at org.apache.cassandra.db.DefsTable.mergeSchema(DefsTable.java:269)
        at org.apache.cassandra.db.DefsTable.mergeRemoteSchema(DefsTable.java:248)
        at org.apache.cassandra.service.MigrationManager$MigrationTask.runMayThrow(MigrationManager.java:416)
        at org.apache.cassandra.utils.WrappedRunnable.run(WrappedRunnable.java:30)
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
        at java.util.concurrent.FutureTask.run(FutureTask.java:166)        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)        at java.lang.Thread.run(Thread.java:636)

I can see that the data I would expect still seems to be in the new place (/var/lib/cassandra/data/App/ColFamily/App-DomainName-*) on all nodes.

What am I missing?

Thanks,
Casey