incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Coli <rc...@palominodb.com>
Subject Re: Adding a second datacenter
Date Thu, 17 May 2012 00:28:26 GMT
On Tue, Apr 24, 2012 at 3:24 PM, Bill Au <bill.w.au@gmail.com> wrote:
> Everything went smoothly until I ran the last step, which is to run nodetool
> repair on all the nodes in the new data center.  Repair is hanging on all
> the new nodes.  I had to hit control-C to break out of it.
> [ snip ]
> Did I missed anything or did something wrong?  How do I recover from this?

http://wiki.apache.org/cassandra/Operations
"
Running nodetool repair: Like all nodetool operations in 0.7, repair
is blocking: it will wait for the repair to finish and then exit. This
may take a long time on large data sets.
"

Since 0.7, all nodetool operations are blocking. While "repair" does
in fact have bugs which make it possible that it will hang in all
extant release versions, the fact that nodetool repair (hopefully you
were using -pr option?) takes a long time to return does not indicate
that it is hanging.

If you see repair and AES messages in system.log, it is probably not
in fact hung. If you don't see said messages for a long time, it might
be hung, in which case the only remedy currently available to you is
to restart the affected nodes.

=Rob
PS - I know this is a reply on a relatively old thread and I think you
maybe received assistance on another thread after this one. If so,
apologies!

-- 
=Robert Coli
AIM&GTALK - rcoli@palominodb.com
YAHOO - rcoli.palominob
SKYPE - rcoli_palominodb

Mime
View raw message