incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Wellonen" <Jason.Wello...@cassidiancommunications.com>
Subject RE: C 1.1 & CQL 2.0 or 3.0?
Date Fri, 11 May 2012 18:00:45 GMT
Version 2 is the default for your connection.
 
Are you using cqlsh?  If so, use the "-3" parameter for version 3...
 

________________________________

From: cyril auburtin [mailto:cyril.auburtin@gmail.com] 
Sent: Friday, May 11, 2012 10:51 AM
To: user@cassandra.apache.org
Subject: C 1.1 & CQL 2.0 or 3.0?


I have C* 1.1 but it seems to only come with cql 2.0 
 INFO 19:35:21,579 Cassandra version: 1.1.0
 INFO 19:35:21,581 Thrift API version: 19.30.0
 INFO 19:35:21,583 CQL supported versions: 2.0.0,3.0.0-beta1 (default:
2.0.0)

the problem is I would like to create such CF :

CREATE COLUMNFAMILY TaggedPosts (
         ...     tag text,
         ...     post uuid,
         ...     blog_rowentries_rowkey text,
         ...     PRIMARY KEY (tag, post)
         ... ) WITH COMPACT STORAGE;

and for me, (cql 2.0) it returns this error

Bad Request: line 6:0 mismatched input ')' expecting EOF

Is it due to the cql version? how to upgrade to 3.0, since I already
have the lastest cassandra release?

Mime
View raw message