incubator-cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michal Michalski <>
Subject Re: User authorized for <modify-keyspace> cannot create CFs
Date Fri, 20 Apr 2012 09:42:29 GMT
Thanks for your reply, problem is solved. First, I missunderstood the 
modify-keyspace param and then I just missed the fact that I can do simply:


without any wildcards or so. I even tried this solution before and - 
after looking into the source code - I was sure it just has to work, but 
it failed baceuse of some other, unrelated error in our app, which I 
missed before.

> AFAIK the SimpleAuthenticator, and to some degree authentication (?), has been essentially
deprecated as it was considered incomplete and was not under development. This is why the
SimpleAuthenticator was moved out to the examples directory in 1.X. I doubt it will be dropped,
but (again AFIK) it is not under active development.

Yup, I know it. But we do not use it as a main way of securing our data 
or so - we just want to (1) separate the access from different parts of 
the system using different users for them and (2) protect ourselves from 
accidental writes to improper keyspaces or so. Thus we don't need it to 
be working perfectly - I'd say it's a bit like Windows95 login prompt, 
which could be closed with Esc button ;) Anyway, even if we threat this 
way, we need it to use it comfortably, so it would be a problem for us 
to change SimpleAuthenticator to AllowAllAuthority in cassandra.yaml 
every time we create/update CF's :)

Anyway, it works now and thanks for your reply :)


View raw message